aboutsummaryrefslogtreecommitdiffstats
path: root/packages/chicken
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-07-25 00:33:16 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-07-25 00:33:16 +0000
commit42133d972e1aae5a13fc3a26f6c0a80456a9dbe7 (patch)
tree6bb8be539738c67caebb4d1c5d6a4586b7215b13 /packages/chicken
parenta3e73146adce111fe67af0886a43acbf7a654bd7 (diff)
downloadopenembedded-42133d972e1aae5a13fc3a26f6c0a80456a9dbe7.tar.gz
chicken: update to 3.3.0. Closes 4433.
Diffstat (limited to 'packages/chicken')
-rw-r--r--packages/chicken/chicken3.inc36
-rw-r--r--packages/chicken/chicken_3.3.0.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/packages/chicken/chicken3.inc b/packages/chicken/chicken3.inc
new file mode 100644
index 0000000000..2feebfb48a
--- /dev/null
+++ b/packages/chicken/chicken3.inc
@@ -0,0 +1,36 @@
+DESCRIPTION = "A compiler that translates Scheme source files to C, and an interpreter"
+HOMEPAGE = "http://www.call-with-current-continuation.org/"
+SECTION = "interpreters"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "http://chicken.wiki.br/releases/${PV}/chicken-${PV}.tar.gz"
+
+inherit autotools
+
+do_compile() {
+ export PLATFORM=linux
+ export PREFIX=${prefix}
+ export HOST=${TARGET_ARCH}-${DISTRO}-${TARGET_OS}
+ export C_COMPILER=${HOST}-gcc
+ export LIBRARIAN=${HOST}-ar
+ # ARCH= is weird... but it's not enough to export this variable.
+ # If ARCH is not set to empty-string, then the Makefile will try to
+ # use the apply-hack.s file applicable to the machine doing the compiling.
+ # There is no such apply-hack assembler code for arm, at least not yet.
+ make ARCH=
+}
+
+do_install() {
+ export PLATFORM=linux
+ export PREFIX=${prefix}
+ export HOST=${TARGET_ARCH}-${DISTRO}-${TARGET_OS}
+ export C_COMPILER=${HOST}-gcc
+ export LIBRARIAN=${HOST}-ar
+ make ARCH= DESTDIR=${D} install
+}
+
+FILES_${PN} = "${bindir}/csi ${bindir}/chicken-bug"
+FILES_${PN} += "${libdir}/lib*.so.* ${libdir}/chicken"
+FILES_${PN} += "${datadir}/chicken/*.*"
+FILES_${PN}-dev += "${bindir}"
diff --git a/packages/chicken/chicken_3.3.0.bb b/packages/chicken/chicken_3.3.0.bb
new file mode 100644
index 0000000000..7d9fc69419
--- /dev/null
+++ b/packages/chicken/chicken_3.3.0.bb
@@ -0,0 +1 @@
+require chicken3.inc