aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ckermit
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/ckermit
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/ckermit')
-rw-r--r--packages/ckermit/ckermit_211.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/packages/ckermit/ckermit_211.bb b/packages/ckermit/ckermit_211.bb
index e69de29bb2..9bf4c2859e 100644
--- a/packages/ckermit/ckermit_211.bb
+++ b/packages/ckermit/ckermit_211.bb
@@ -0,0 +1,92 @@
+DESCRIPTION = "C-Kermit is a combined serial and network communication \
+software package offering a consistent, medium-independent, \
+cross-platform approach to connection establishment, terminal \
+sessions, file transfer, character-set translation, and automation \
+of communication tasks."
+LICENSE = "Kermit"
+MAINTAINER = "Holger Schurig"
+HOMEPAGE = "http://www.columbia.edu/kermit/"
+SECTION = "console/network"
+SRC_URI = "ftp://kermit.columbia.edu/kermit/archives/cku${PV}.tar.gz"
+
+#
+# From http://www.columbia.edu/kermit/ck80.html#license
+#
+# "Free Unix Distributions: C-Kermit may be included in "free Unix"
+# distributions such as GNU/Linux, FreeBSD, NetBSD, and OpenBSD. See the
+# license for details."
+#
+# A distributions based on OpenEmbedded (OpenZaurus, OpenSimpad etc) is a
+# "free Unix" distribution, therefore we can include the package.
+#
+#
+# Please note that the license is not 100% because it limits what you can
+# do:
+#
+# "The C-Kermit source code may not be changed without the consent of
+# the Kermit Project, which will not be unreasonably withheld (this is
+# simply a matter of keeping a consistent and supportable code base)."
+#
+# But we don't change the source code in any way, so we comply to the license.
+# So, essentially for us C-Kermit is free as in beer, but not in freedom.
+#
+# That is true for other distros. C-Kkermit is distributed by:
+#
+# Debian: http://packages.debian.org/unstable/comm/ckermit
+# Gentoo: http://mirror.pudas.net/gentoo-x86-portage/app-misc/ckermit/ckermit-8.0.211.ebuild
+# SuSE: http://www.novell.com/products/linuxpackages/enterpriseserver/s390/ckermit.html
+# Fedora Core: http://cvs.fedora.redhat.com/viewcvs/devel/ckermit/
+# PLD: http://cvs.pld.org.pl/SPECS/ckermit.spec
+#
+# and, according to the Kermit website http://www.columbia.edu/kermit/ck80.html also with
+#
+# Red Hat 9 (on earlier Red Hat's it was on the PowerTools CD)
+# HP-UX
+# FreeBSD
+# NetBSD
+# OpenBSD
+#
+# ... and probably other distro's as well.
+#
+
+
+
+python do_unpack () {
+ bb.mkdirhier(bb.data.expand('${S}', d))
+ bb.build.exec_func('base_do_unpack', d, [ '${S}' ])
+}
+
+
+
+export CC2 = "${CC}"
+export BINDIR = "${bindir}"
+export MANDIR = "${mandir}/man1"
+export INFODIR = "${infodir}"
+
+do_compile () {
+ # The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
+ # so we build wart manually. Note that you need a ckwart.o with the proper
+ # timestamp to make this hack work:
+ ${BUILD_CC} -c ckwart.c
+ ${BUILD_CC} -o wart ckwart.o
+ ./wart ckcpro.w ckcpro.c
+
+ # read ${S}/ckccfg.txt to understand this :-)
+ oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
+ -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
+ -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
+ -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
+ -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
+ -DNOB_460K -DNOB_921K \
+ -DNOAPC -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
+ -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
+ -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
+ -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
+ -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
+ -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI"
+}
+
+do_install () {
+ install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR}
+ oe_runmake 'DESTDIR=${D}' 'MANDIR=${D}${MANDIR}' install
+}