aboutsummaryrefslogtreecommitdiffstats
path: root/packages/clamav
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-19 22:15:28 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-19 22:15:28 +0000
commitca4bb42ee3d1d9e2ffba172a831a645723565a36 (patch)
treec1ce91fc8cbda05d27f355b08bc237788454d1ad /packages/clamav
parent06c755eb8ea36b4334d91ce8a39da512cbc26ed8 (diff)
downloadopenembedded-ca4bb42ee3d1d9e2ffba172a831a645723565a36.tar.gz
clamav 0.88.4: Add a do_stage to stage the header files and libraries so
other applications that link against clamav can be build. Some spelling fixes in the comments as well.
Diffstat (limited to 'packages/clamav')
-rw-r--r--packages/clamav/clamav_0.88.4.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/packages/clamav/clamav_0.88.4.bb b/packages/clamav/clamav_0.88.4.bb
index d0d503eadb..46322bd8cd 100644
--- a/packages/clamav/clamav_0.88.4.bb
+++ b/packages/clamav/clamav_0.88.4.bb
@@ -16,7 +16,7 @@ RDEPENDS_${PN} = "${PN}-data"
RDEPENDS_${PN}-daemon = "${PN}-data"
RRECOMMENDS_${PN} = "${PN}-freshclam"
RRECOMMENDS_${PN}-daemon = "${PN}-freshclam"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/clamav/clamav-${PV}.tar.gz \
file://cross-compile-fix.patch;patch=1 \
@@ -37,10 +37,10 @@ EXTRA_OECONF = "--disable-clamav \
do_install_append() {
install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d \
${D}${docdir}/clamav
- # Save the installed clamd.conf in the doc dir and then install out new one
+ # Save the installed clamd.conf in the doc dir and then install our new one
install -m 0755 ${D}${sysconfdir}/clamd.conf ${D}${docdir}/clamav/clamd.conf.example
install -m 0755 ${WORKDIR}/clamd.conf ${D}${sysconfdir}/clamd.conf
- # Save the installed freshclam.conf in the doc dir and then install out new one
+ # Save the installed freshclam.conf in the doc dir and then install our new one
install -m 0755 ${D}${sysconfdir}/freshclam.conf ${D}${docdir}/clamav/freshclam.conf.example
# Install our config files and init scripts
install -m 0755 ${WORKDIR}/freshclam.conf ${D}${sysconfdir}/freshclam.conf
@@ -48,6 +48,10 @@ do_install_append() {
install -m 0755 ${WORKDIR}/clamav-daemon.init ${D}${sysconfdir}/init.d/clamav-daemon
install -m 0755 ${WORKDIR}/clamav-freshclam.init ${D}${sysconfdir}/init.d/clamav-freshclam
}
+do_stage () {
+ oe_libinstall -a -so libclamav ${STAGING_LIBDIR}
+ install -m 0644 libclamav/clamav.h ${STAGING_INCDIR}
+}
PACKAGES += "${PN}-freshclam ${PN}-daemon ${PN}-data ${PN}-lib"
@@ -89,7 +93,7 @@ pkg_postinst_${PN}-data () {
CONFFILES_${PN}-daemon = "${sysconfdir}/clamd.conf \
${sysconfdir}/default/clamav-daemon"
CONFFILES_${PN}-freshclam = "${sysconfdir}/freshclam.conf"
-# Make the database as conffiles so that newwer data file won't replace
+# Mark the database as conffiles so that newer data file won't replace
# updates generated by freshclam
CONFFILES_${PN}-data = "${localstatedir}/lib/clamav/main.cvd \
${localstatedir}/lib/clamav/daily.cvd"