aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-04-09 00:18:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-09 00:18:32 +0000
commit9712305857c6c5e0e09f98d60ca4b41326af2ea6 (patch)
tree86d41ff458be09ecc9bffc7666f0c8ad415210b6 /packages/classpath
parentb011df19112cef97dae6f7a7c9b1b7734965856f (diff)
downloadopenembedded-9712305857c6c5e0e09f98d60ca4b41326af2ea6.tar.gz
classpath: add 0.90. Fixes AWT breakage experienced with 0.18.
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath_0.90.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/classpath/classpath_0.90.bb b/packages/classpath/classpath_0.90.bb
new file mode 100644
index 0000000000..4b4647f974
--- /dev/null
+++ b/packages/classpath/classpath_0.90.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "GNU Classpath standard Java libraries"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "libs"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango xtst jikes-native zip-native"
+RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
+
+SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-jikes --disable-alsa"
+
+PACKAGES += " ${PN}-common ${PN}-examples"
+
+FILES_${PN} = "${libdir}/${PN}"
+FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/classpath
+ install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
+}
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}