aboutsummaryrefslogtreecommitdiffstats
path: root/packages/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/console-tools/console-tools_0.3.2.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/console-tools/console-tools_0.3.2.bb')
-rw-r--r--packages/console-tools/console-tools_0.3.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/console-tools/console-tools_0.3.2.bb b/packages/console-tools/console-tools_0.3.2.bb
index e69de29bb2..7cf684c589 100644
--- a/packages/console-tools/console-tools_0.3.2.bb
+++ b/packages/console-tools/console-tools_0.3.2.bb
@@ -0,0 +1,25 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
+ file://codepage.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://compile.patch;patch=1 \
+ file://config/*.m4"
+
+export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
+ examples po intl compat"
+
+acpaths = "-I config"
+do_configure_prepend () {
+ mkdir -p config
+ cp ${WORKDIR}/config/*.m4 config/
+}
+
+do_compile () {
+ oe_runmake -C lib
+ oe_runmake 'SUBDIRS=${SUBDIRS}'
+}
+
+inherit autotools