aboutsummaryrefslogtreecommitdiffstats
path: root/packages/coreutils/coreutils_5.1.3.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-23 23:36:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-23 23:36:33 +0000
commitc058e136fb5fa00332077cc9526f2b1ae28bae17 (patch)
treed62d8263162c17fab3c1f1ad8af383f27a00bed4 /packages/coreutils/coreutils_5.1.3.bb
parentb14aeb2b4e4fbc57bddc33b8749cf9aee03e2a4a (diff)
downloadopenembedded-c058e136fb5fa00332077cc9526f2b1ae28bae17.tar.gz
Use of [.coreutils caused problems because the coreutils [ link ended up
being called \[ (update-alternatives cannot handle an unescaped [). Fixed by using lbracket.coreutils (based on the actual source name of the .c file used to build this.)
Diffstat (limited to 'packages/coreutils/coreutils_5.1.3.bb')
-rw-r--r--packages/coreutils/coreutils_5.1.3.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/packages/coreutils/coreutils_5.1.3.bb b/packages/coreutils/coreutils_5.1.3.bb
index 47c734446f..0d7a783663 100644
--- a/packages/coreutils/coreutils_5.1.3.bb
+++ b/packages/coreutils/coreutils_5.1.3.bb
@@ -3,7 +3,7 @@ SECTION = "base"
DESCRIPTION = "A collection of core GNU utilities."
RREPLACES = "textutils shellutils fileutils"
RPROVIDES = "textutils shellutils fileutils"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
@@ -31,7 +31,10 @@ do_install () {
# Renaming the utilities that should go in /usr/bin
for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
- mv ${D}${bindir}/[ ${D}${bindir}/[.${PN}
+ # [ requires special handling because [.coreutils will cause the sed stuff
+ # in update-alternatives to fail, therefore use lbracket - the name used
+ # for the actual source file.
+ mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
# Renaming and moving the utilities that should go in /bin (FHS)
install -d ${D}${base_bindir}
@@ -45,7 +48,7 @@ do_install () {
pkg_postinst_${PN} () {
# The utilities in /usr/bin
for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
- update-alternatives --install "${bindir}/\[" "\[" "\[.${PN}" 100
+ update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
# The utilities in /bin
for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
@@ -57,7 +60,7 @@ pkg_postinst_${PN} () {
pkg_prerm_${PN} () {
# The utilities in /usr/bin
for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
- update-alternatives --remove "\[" "\[.${PN}"
+ update-alternatives --remove '[' 'lbracket.${PN}'
# The utilities in /bin
for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done