aboutsummaryrefslogtreecommitdiffstats
path: root/packages/coreutils
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-07-26 11:48:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-26 11:48:50 +0000
commitf2e1da7559d1798ae8314d8824c8d53da0b3506b (patch)
tree028e37996f930ea4119c786159bb3e33edcd61e9 /packages/coreutils
parent18063cd1759f0c631d2f59aefd428560904b8555 (diff)
downloadopenembedded-f2e1da7559d1798ae8314d8824c8d53da0b3506b.tar.gz
coreutils hostname doesn't support -F, put at lower priority so the working one (busybox) gets linked instead
Diffstat (limited to 'packages/coreutils')
-rw-r--r--packages/coreutils/coreutils_5.1.3.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/packages/coreutils/coreutils_5.1.3.bb b/packages/coreutils/coreutils_5.1.3.bb
index 0d7a783663..cced8b00e7 100644
--- a/packages/coreutils/coreutils_5.1.3.bb
+++ b/packages/coreutils/coreutils_5.1.3.bb
@@ -3,7 +3,7 @@ SECTION = "base"
DESCRIPTION = "A collection of core GNU utilities."
RREPLACES = "textutils shellutils fileutils"
RPROVIDES = "textutils shellutils fileutils"
-PR = "r3"
+PR = "r4"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
@@ -11,6 +11,7 @@ SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
inherit autotools
+# [ gets a special treatment and is not included in this
bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
env expand expr factor fmt fold groups head hostid id install \
join link logname md5sum mkfifo nice nl nohup od paste pathchk \
@@ -19,7 +20,8 @@ bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
unlink uptime users vdir wc who whoami yes \
"
-base_bindir_progs = "cat chgrp chmod chown cp date dd echo false hostname kill \
+# hostname gets a special treatment and is not included in this
+base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
true uname \
"
@@ -39,6 +41,7 @@ do_install () {
# Renaming and moving the utilities that should go in /bin (FHS)
install -d ${D}${base_bindir}
for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
+ mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
# Renaming and moving the utilities that should go in /usr/sbin (FHS)
install -d ${D}${sbindir}
@@ -52,6 +55,8 @@ pkg_postinst_${PN} () {
# The utilities in /bin
for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
+ # coreutils hostname is retarded and doesn't know about -F, put at priority 10
+ update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
# The utilities in /usr/sbin
for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
@@ -64,6 +69,7 @@ pkg_prerm_${PN} () {
# The utilities in /bin
for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+ update-alternatives --remove hostname hostname.${PN}
# The utilities in /usr/sbin
for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done