aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cpusage/cpusage_0.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-04-04 21:41:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-04 21:41:30 +0000
commitf6d5785f33bcec280086c2e5fbd8bee727578f74 (patch)
treeb35a848d4d954561d8e921c6b9b8fd00939c8d7f /packages/cpusage/cpusage_0.2.bb
parent828297a014310af03afc7a245eea93f2576f9ba3 (diff)
downloadopenembedded-f6d5785f33bcec280086c2e5fbd8bee727578f74.tar.gz
cpusage: Add 0.1 and 0.2 (from Stelios Koroneos #775)
Diffstat (limited to 'packages/cpusage/cpusage_0.2.bb')
-rw-r--r--packages/cpusage/cpusage_0.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/cpusage/cpusage_0.2.bb b/packages/cpusage/cpusage_0.2.bb
new file mode 100644
index 0000000000..7d4df4eccf
--- /dev/null
+++ b/packages/cpusage/cpusage_0.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "This tool read out the tics counter of the operating system and \
+calculates the Percentages spend in each CPU_STATE."
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz"
+
+S = "${WORKDIR}/cpusage-${PV}"
+
+FILES_${PN} = "/sbin/cpusage"
+
+CFLAGS_append =" -D_BSD_SOURCE=1"
+CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
+
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
+}
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install -m 0755 cpusage ${D}${base_sbindir}/cpusage
+}