aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cron
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/cron
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/cron')
-rw-r--r--packages/cron/.mtn2git_empty0
-rw-r--r--packages/cron/cron-3.0pl1/.mtn2git_empty0
-rw-r--r--packages/cron/cron-3.0pl1/nonrootinstall.patch28
-rw-r--r--packages/cron/cron-3.0pl1/time.patch16
4 files changed, 44 insertions, 0 deletions
diff --git a/packages/cron/.mtn2git_empty b/packages/cron/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cron/.mtn2git_empty
diff --git a/packages/cron/cron-3.0pl1/.mtn2git_empty b/packages/cron/cron-3.0pl1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cron/cron-3.0pl1/.mtn2git_empty
diff --git a/packages/cron/cron-3.0pl1/nonrootinstall.patch b/packages/cron/cron-3.0pl1/nonrootinstall.patch
index e69de29bb2..375862d905 100644
--- a/packages/cron/cron-3.0pl1/nonrootinstall.patch
+++ b/packages/cron/cron-3.0pl1/nonrootinstall.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- cron3.0pl1/Makefile~nonrootinstall
++++ cron3.0pl1/Makefile
+@@ -77,6 +77,9 @@
+ #<<the name of the BSD-like install program>>
+ #INSTALL = installbsd
+ INSTALL = install
++ifeq ($(DESTDIR),)
++INSTALLOWN = -o root
++endif
+ #<<any special load flags>>
+ LDFLAGS =
+ #################################### end configurable stuff
+@@ -113,8 +116,8 @@
+ $(CC) $(LDFLAGS) -o crontab $(CRONTAB_OBJ) $(LIBS)
+
+ install : all
+- $(INSTALL) -c -m 111 -o root -s cron $(DESTSBIN)/
+- $(INSTALL) -c -m 4111 -o root -s crontab $(DESTBIN)/
++ $(INSTALL) -c -m 111 $(INSTALLOWN) -s cron $(DESTSBIN)/
++ $(INSTALL) -c -m 4111 $(INSTALLOWN) -s crontab $(DESTBIN)/
+ sh putman.sh crontab.1 $(DESTMAN)
+ sh putman.sh cron.8 $(DESTMAN)
+ sh putman.sh crontab.5 $(DESTMAN)
diff --git a/packages/cron/cron-3.0pl1/time.patch b/packages/cron/cron-3.0pl1/time.patch
index e69de29bb2..c172984a85 100644
--- a/packages/cron/cron-3.0pl1/time.patch
+++ b/packages/cron/cron-3.0pl1/time.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- cron3.0pl1/compat.h~time
++++ cron3.0pl1/compat.h
+@@ -114,7 +114,7 @@
+ # define USE_SIGCHLD
+ #endif
+
+-#if !defined(AIX) && !defined(UNICOS)
++#if !defined(AIX) && !defined(UNICOS) && !defined(__linux)
+ # define SYS_TIME_H 1
+ #else
+ # define SYS_TIME_H 0