aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cups
diff options
context:
space:
mode:
authorJake Morrison <jake@cogini.com>2007-07-15 18:21:20 +0000
committerJustin Patrin <papercrane@gmail.com>2007-07-15 18:21:20 +0000
commit2a459e94bce798e983c094c88b56336bb3a741e7 (patch)
tree8a3df7d4efc2106473d2d033b94fd7cd2536c0ce /packages/cups
parent146eaf43853b2e16f7bc3d6a08069c1416f742af (diff)
downloadopenembedded-2a459e94bce798e983c094c88b56336bb3a741e7.tar.gz
cups: fix packaging error and add LEAD_SONAME (bug 2345)
Diffstat (limited to 'packages/cups')
-rw-r--r--packages/cups/cups_1.2.10.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/packages/cups/cups_1.2.10.bb b/packages/cups/cups_1.2.10.bb
index 8201dd9201..2e4498255c 100644
--- a/packages/cups/cups_1.2.10.bb
+++ b/packages/cups/cups_1.2.10.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "An Internet printing system for Unix."
SECTION = "console/utils"
LICENSE = "GPL LGPL"
DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib install-native fakeroot-native"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
"
@@ -46,6 +46,9 @@ do_compile () {
fakeroot do_install () {
oe_runmake "DSTROOT=${D}" install
+
+ # This directory gets installed with perms 511, which makes packaging fail
+ chmod 0711 "${D}/${localstatedir}/run/cups/certs"
}
do_stage () {
@@ -56,6 +59,12 @@ do_stage () {
oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
}
+python do_package_append() {
+ # Change permissions back the way they were, they probably had a reason...
+ workdir = bb.data.getVar('WORKDIR', d, 1)
+ os.system('chmod 0511 %s/install/cups/var/run/cups/certs' % workdir)
+}
+
FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
${libdir}/cups/cgi-bin/.debug \
${libdir}/cups/filter/.debug \
@@ -71,6 +80,4 @@ FILES_${PN} += "${datadir}/doc/cups/images \
${datadir}/icons/ \
"
-
-
-
+LEAD_SONAME = "libcups.so.*" \ No newline at end of file