aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cups
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-05 18:30:54 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-05 18:30:54 +0000
commit813018a1addca1409534e44aed4084708984e088 (patch)
tree9237b5152db0065b066741bb5ff3867142f22aa0 /packages/cups
parentc50d4a36fd559073dd05edfc80b3244baf49a593 (diff)
downloadopenembedded-813018a1addca1409534e44aed4084708984e088.tar.gz
cups: add 1.2.7, a recipe with less hacks as 1.1.13
Diffstat (limited to 'packages/cups')
-rw-r--r--packages/cups/cups_1.2.7.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/packages/cups/cups_1.2.7.bb b/packages/cups/cups_1.2.7.bb
new file mode 100644
index 0000000000..e49a4466a5
--- /dev/null
+++ b/packages/cups/cups_1.2.7.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "An Internet printing system for Unix."
+SECTION = "console/utils"
+LICENSE = "GPL LGPL"
+DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib install-native fakeroot-native"
+PR = "r0"
+
+SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
+ "
+
+inherit autotools binconfig
+
+LDFLAGS += " -L${STAGING_LIBDIR} "
+
+EXTRA_OECONF = " \
+ --enable-gnutls \
+ --enable-dbus \
+ --enable-browsing \
+ --disable-openssl \
+ --disable-tiff \
+ "
+
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_compile () {
+ sed -i s:STRIP:NOSTRIP: Makedefs
+ sed -i s:serial:: backend/Makefile
+
+ echo "all:" > man/Makefile
+ echo "install:" >> man/Makefile
+
+ oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
+ "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
+ "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
+ "LIBZ=-lz -L${STAGING_LIBDIR}" \
+ "-I."
+}
+
+fakeroot do_install () {
+ oe_runmake "DSTROOT=${D}" install
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/cups
+ install ${S}/cups/*.h ${STAGING_INCDIR}/cups/
+ install ${S}/filter/*.h ${STAGING_INCDIR}/cups/
+ oe_libinstall -C cups -so libcups ${STAGING_LIBDIR}
+ oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
+}
+
+#package the html for the webgui inside the main packages (~1MB uncompressed)
+FILES_${PN} += "${datadir}/doc/cups/images \
+ ${datadir}/doc/cups/*html \
+ ${datadir}/doc/cups/*.css \
+ ${datadir}/icons/ \
+ "
+
+
+
+