aboutsummaryrefslogtreecommitdiffstats
path: root/packages/curl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-09 23:08:49 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-09 23:08:49 +0000
commit45b8741f7b138d039e0b1107ba1f1d41f61b5f26 (patch)
treeb69378d247af749ee22668c35ae64a26f49fbaf1 /packages/curl
parentcc66d34e4a411ce7e105df2ecb3d95265157f267 (diff)
downloadopenembedded-45b8741f7b138d039e0b1107ba1f1d41f61b5f26.tar.gz
Third (and hopefully last) EFL revamp before I hand over maintainership to
Justin Patrin. We now have a efl.bbclass that contains common code for the various libraries. This makes it possible to have very clean and concise bb's.
Diffstat (limited to 'packages/curl')
-rw-r--r--packages/curl/curl-native_7.14.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/curl/curl-native_7.14.0.bb b/packages/curl/curl-native_7.14.0.bb
index 0fc2e14452..59af4ef32e 100644
--- a/packages/curl/curl-native_7.14.0.bb
+++ b/packages/curl/curl-native_7.14.0.bb
@@ -1,6 +1,12 @@
include curl_${PV}.bb
inherit native
+do_stage () {
+ install -d ${STAGING_INCDIR}/curl
+ install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
+ oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
+}
+
do_install() {
:
}