aboutsummaryrefslogtreecommitdiffstats
path: root/packages/curl
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-02-02 22:22:17 +0000
committerChris Larson <clarson@kergoth.com>2005-02-02 22:22:17 +0000
commit4d10c42d0fa2ab1119bea9641f0ffbd89603e61a (patch)
tree79cef4f15dd80c27c595d5fa729a5891a7bb6853 /packages/curl
parent4b8897c13c21aad8c1d44574ff44bd1cb2837798 (diff)
downloadopenembedded-4d10c42d0fa2ab1119bea9641f0ffbd89603e61a.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into handhelds.org:/home/kergoth/code/openembedded 2005/02/02 17:21:43-05:00 handhelds.org!kergoth Fix curl build with uclibc. BKrev: 420152997dH-JC_Adi_JEFcQxcOK8Q
Diffstat (limited to 'packages/curl')
-rw-r--r--packages/curl/curl_7.12.2.bb44
-rw-r--r--packages/curl/files/uclibc.patch0
2 files changed, 44 insertions, 0 deletions
diff --git a/packages/curl/curl_7.12.2.bb b/packages/curl/curl_7.12.2.bb
index e69de29bb2..a483c1275e 100644
--- a/packages/curl/curl_7.12.2.bb
+++ b/packages/curl/curl_7.12.2.bb
@@ -0,0 +1,44 @@
+# NOTE: FIXME: curl puts its LDFLAGS in its curl-config and curl.pc files.
+# This is flawed, as the LDFLAGS are often overridden by the user, and in
+# addition, are generally specific to the *build* environment, not target.
+# curl's build should be fixed to manipulate LIBS where appropriate and
+# use that. -CL
+
+DEPENDS = "zlib"
+DESCRIPTION = "Command line tool and library for \
+client-side URL transfers."
+LICENSE = "MIT"
+SECTION = "console/network"
+PR = "r2"
+
+SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
+ file://uclibc.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
+ --without-ssl --with-random=/dev/urandom"
+
+PACKAGES = "curl curl-doc libcurl libcurl-dev libcurl-doc"
+FILES_${PN} = "${bindir}/curl"
+FILES_${PN}-doc = "${mandir}/man1/curl.1"
+FILES_lib${PN} = "${libdir}/lib*.so.*"
+FILES_lib${PN}-dev = "${includedir} \
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.a \
+ ${libdir}/lib*.la \
+ ${libdir}/pkgconfig \
+ ${datadir}/aclocal \
+ ${bindir}/*-config"
+FILES_lib${PN}-doc = "${mandir}/man3 \
+ ${mandir}/man1/curl-config.1"
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/curl
+ install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
+ oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
+
+ cat curl-config | sed -e "s,-I/usr/include,-I${STAGING_INCDIR}/," \
+ | sed -e "s,-L/usr/lib , , "> ${STAGING_BINDIR}/curl-config
+ chmod a+rx ${STAGING_BINDIR}/curl-config
+}
diff --git a/packages/curl/files/uclibc.patch b/packages/curl/files/uclibc.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/curl/files/uclibc.patch