aboutsummaryrefslogtreecommitdiffstats
path: root/packages/curl
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2008-09-07 15:59:50 +0000
committerPhil Blundell <philb@gnu.org>2008-09-07 15:59:50 +0000
commit32ecaa1a4d19830254af9357f14b417ad4e82166 (patch)
treea4b4cd113d782b419fa0b65d462f75a90cd590ad /packages/curl
parent5a4d1ac56a5590c38c514ba8fa0fa2081c9da74d (diff)
downloadopenembedded-32ecaa1a4d19830254af9357f14b417ad4e82166.tar.gz
curl: make parameters configurable via CURL_FEATURES
Diffstat (limited to 'packages/curl')
-rw-r--r--packages/curl/curl.inc38
1 files changed, 33 insertions, 5 deletions
diff --git a/packages/curl/curl.inc b/packages/curl/curl.inc
index ae2cff6e10..d3edaef20a 100644
--- a/packages/curl/curl.inc
+++ b/packages/curl/curl.inc
@@ -1,23 +1,51 @@
DESCRIPTION = "Command line tool and library for client-side URL transfers."
LICENSE = "MIT"
-DEPENDS = "zlib gnutls"
SECTION = "console/network"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch;patch=1"
S = "${WORKDIR}/curl-${PV}"
+CURL_FEATURES ?= "zlib,gnutls,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp"
+# other allowed features: ipv6, ares
+
inherit autotools pkgconfig binconfig
-EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
- --with-gnutls=${STAGING_BINDIR_CROSS}/ \
- --without-ssl \
+EXTRA_OECONF = " \
--without-libssh2 \
--with-random=/dev/urandom \
--without-libidn \
- --enable-crypto-auth \
+ --without-ssl \
"
+python __anonymous() {
+ f = bb.data.getVar("CURL_FEATURES", d, True).split(",")
+ oeconf = bb.data.getVar("EXTRA_OECONF", d, False)
+ deps = bb.data.getVar("DEPENDS", d, False).split()
+ for x in [ 'cookies', 'crypto-auth', 'dict', 'file', 'ftp', 'http', 'telnet', 'tftp', 'ipv6' ]:
+ if x in f:
+ oeconf += " --enable-%s" % x
+ else:
+ oeconf += " --disable-%s" % x
+ if 'zlib' in f:
+ oeconf += " --with-zlib=${STAGING_LIBDIR}/../"
+ deps.append("zlib")
+ else:
+ oeconf += " --without-zlib"
+ if 'gnutls' in f:
+ oeconf += " --with-gnutls=${STAGING_BINDIR_CROSS}"
+ deps.append("gnutls")
+ else:
+ oeconf += " --without-gnutls"
+ if 'ares' in f:
+ oeconf += " --enable-ares"
+ deps.append("c-ares")
+ else:
+ oeconf += " --disable-ares"
+ bb.data.setVar('EXTRA_OECONF', oeconf, d)
+ bb.data.setVar('DEPENDS', " ".join(deps), d)
+}
+
do_configure_prepend() {
sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac
}