aboutsummaryrefslogtreecommitdiffstats
path: root/packages/custominput/custominput_1.1.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/custominput/custominput_1.1.0.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/custominput/custominput_1.1.0.bb')
-rw-r--r--packages/custominput/custominput_1.1.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/custominput/custominput_1.1.0.bb b/packages/custominput/custominput_1.1.0.bb
index e69de29bb2..3becdc2df1 100644
--- a/packages/custominput/custominput_1.1.0.bb
+++ b/packages/custominput/custominput_1.1.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Custom Keyboard \
+Keyboard that can be customized to include exactly the characters that the user uses, but which is not available on his physical keyboard."
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.blackie.dk/Zaurus/custominput/"
+AUTHOR = "Jesper Kjaer Pedersen <blackie@blackie.dk>"
+
+SRC_URI = "http://www.blackie.dk/Zaurus/custominput/custominput-1.1.0.tgz"
+
+inherit palmtop
+
+QMAKE_PROFILES = "custominput.pro"
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S}"
+
+do_configure_prepend() {
+ find ${S} -name Makefile|xargs rm
+}
+
+do_install() {
+
+ install -d ${D}${palmtopdir}/plugins/inputmethods/ \
+ ${D}${palmtopdir}/pics/ \
+ ${D}${palmtopdir}/bin/ \
+ ${D}${palmtopdir}/apps/ \
+ ${D}${palmtopdir}/apps/Settings/ \
+ ${D}${palmtopdir}/help/html/
+
+ install -m 0755 ${S}/customInputConfig ${D}${palmtopdir}/bin/
+ install -m 0644 ${S}/custominput.desktop ${D}${palmtopdir}/apps/Settings/
+ install -m 0644 ${S}/customInputConfig.html ${D}${palmtopdir}/help/html/
+ install -m 0644 ${S}/custominput.png ${D}${palmtopdir}/pics/
+ oe_libinstall -so -C ${S}/ libcustominput ${D}${palmtopdir}/plugins/inputmethods/
+
+}