aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-07 02:19:36 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-07 02:19:36 +0000
commit7e340da9a026414246a97648c3f10edd788e49d6 (patch)
tree1009f3dd81b9a0ce26daf217814f8152a5b2e8a6 /packages/dbus
parentd045b43b1b6596aab41fcb4aee4df52df60b4434 (diff)
downloadopenembedded-7e340da9a026414246a97648c3f10edd788e49d6.tar.gz
add dbus-c++[-native], a native C++ binding to the DBUS API
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-c++-native_svn.bb6
-rw-r--r--packages/dbus/dbus-c++/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-c++/fix-linking.patch13
-rw-r--r--packages/dbus/dbus-c++_svn.bb23
4 files changed, 42 insertions, 0 deletions
diff --git a/packages/dbus/dbus-c++-native_svn.bb b/packages/dbus/dbus-c++-native_svn.bb
new file mode 100644
index 0000000000..96eb2f3227
--- /dev/null
+++ b/packages/dbus/dbus-c++-native_svn.bb
@@ -0,0 +1,6 @@
+require dbus-c++_${PV}.bb
+inherit native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-c++"
+# actually dbus-native and expat-native, but even the bearest build machine should have that nowadays...
+DEPENDS = ""
diff --git a/packages/dbus/dbus-c++/.mtn2git_empty b/packages/dbus/dbus-c++/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-c++/.mtn2git_empty
diff --git a/packages/dbus/dbus-c++/fix-linking.patch b/packages/dbus/dbus-c++/fix-linking.patch
new file mode 100644
index 0000000000..822216916b
--- /dev/null
+++ b/packages/dbus/dbus-c++/fix-linking.patch
@@ -0,0 +1,13 @@
+Index: dbus/tools/Makefile.am
+===================================================================
+--- dbus.orig/tools/Makefile.am
++++ dbus/tools/Makefile.am
+@@ -16,7 +16,7 @@ endif
+ bin_PROGRAMS = dbusxx-xml2cpp dbusxx-introspect
+
+ dbusxx_xml2cpp_SOURCES = xml.h xml.cpp xml2cpp.h xml2cpp.cpp
+-dbusxx_xml2cpp_LDADD = $(libdbus_cxx_la)
++dbusxx_xml2cpp_LDADD = $(libdbus_cxx_la) -lexpat
+
+ dbusxx_introspect_SOURCES = introspect.h introspect.cpp
+ dbusxx_introspect_LDADD = $(libdbus_cxx_la)
diff --git a/packages/dbus/dbus-c++_svn.bb b/packages/dbus/dbus-c++_svn.bb
new file mode 100644
index 0000000000..ea6c0fa8ea
--- /dev/null
+++ b/packages/dbus/dbus-c++_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "C++ bindings for dbus"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "dbus dbus-c++-native expat"
+
+SRC_URI = "svn://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs;module=dbus;proto=http \
+ file://fix-linking.patch;patch=1"
+S = "${WORKDIR}/dbus"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ find . -name "Makefile.am" |xargs sed -i -e 's,$(top_builddir)/tools/dbusxx-xml2cpp,dbusxx-xml2cpp,'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dbg += "${bindir}/dbusxx-xml2cpp ${bindir}/dbusxx-introspect"
+FILES_${PN}-dev += "${bindir}/.dev"
+FILES_${PN} = "${libdir}/*.so.*"
+