aboutsummaryrefslogtreecommitdiffstats
path: root/packages/devlabel
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/devlabel
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/devlabel')
-rw-r--r--packages/devlabel/devlabel_0.45.01.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/devlabel/devlabel_0.45.01.bb b/packages/devlabel/devlabel_0.45.01.bb
index e69de29bb2..d401ce2b2e 100644
--- a/packages/devlabel/devlabel_0.45.01.bb
+++ b/packages/devlabel/devlabel_0.45.01.bb
@@ -0,0 +1,24 @@
+SECTION = "base"
+HOMEPAGE = "http://linux.dell.com/devlabel/devlabel.html"
+DESCRIPTION = "tool for user-define static device labels"
+DEPENDS = "e2fsprogs-libs"
+LICENSE = "GPL"
+
+SRC_URI = "http://linux.dell.com/devlabel/permalink/devlabel-${PV}.tar.gz"
+
+do_compile () {
+ set -x
+ ${CC} ${CFLAGS} ${LDFLAGS} -o scsi_unique_id scsi_unique_id.c
+ ${CC} ${CFLAGS} ${LDFLAGS} -o partition_uuid partition_uuid.c -luuid
+ set +x
+}
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${bindir} ${D}/${mandir}/man8 \
+ ${D}/${sysconfdir}/sysconfig/devlabel.d
+ install -m 755 devlabel ${D}/${base_sbindir}/devlabel
+ install -m 755 scsi_unique_id ${D}${bindir}/
+ install -m 755 partition_uuid ${D}${bindir}/
+ install -m 644 devlabel.8.gz ${D}${mandir}/man8/
+ install -m 644 sysconfig.devlabel ${D}${sysconfdir}/sysconfig/devlabel
+}