aboutsummaryrefslogtreecommitdiffstats
path: root/packages/directfb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-20 10:33:53 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-20 10:33:53 +0000
commitc557c0fa98fc000c0fec2a3db8bd13378705eac0 (patch)
treed11276cb1e776c73adb2b1c65d1579727bb2d7bf /packages/directfb
parent0985aab11d4a6ecf875257450b1cb553169fd920 (diff)
downloadopenembedded-c557c0fa98fc000c0fec2a3db8bd13378705eac0.tar.gz
directfb update:
* bump ++dfb to 1.0.0 * bump examples to 1.0.0 * bump fusionsound to 1.0.0 * clean up a bit
Diffstat (limited to 'packages/directfb')
-rw-r--r--packages/directfb/++dfb_1.0.0.bb (renamed from packages/directfb/++dfb_0.9.25.bb)0
-rw-r--r--packages/directfb/directfb-examples_1.0.0.bb (renamed from packages/directfb/directfb-examples_0.9.25.bb)13
-rw-r--r--packages/directfb/directfb_1.0.0.bb12
-rw-r--r--packages/directfb/files/fix-includes.patch8
-rw-r--r--packages/directfb/files/fix-pkgconfig-specs.patch47
-rw-r--r--packages/directfb/fusionsound_0.9.26+cvs20070207.bb37
-rw-r--r--packages/directfb/fusionsound_1.0.0.bb37
7 files changed, 82 insertions, 72 deletions
diff --git a/packages/directfb/++dfb_0.9.25.bb b/packages/directfb/++dfb_1.0.0.bb
index f440e117ff..f440e117ff 100644
--- a/packages/directfb/++dfb_0.9.25.bb
+++ b/packages/directfb/++dfb_1.0.0.bb
diff --git a/packages/directfb/directfb-examples_0.9.25.bb b/packages/directfb/directfb-examples_1.0.0.bb
index 28de29c4a6..8a792b4ae4 100644
--- a/packages/directfb/directfb-examples_0.9.25.bb
+++ b/packages/directfb/directfb-examples_1.0.0.bb
@@ -1,10 +1,10 @@
-DESCRIPTION = "DirectFB examples"
+DESCRIPTION = "DirectFB extra providers"
DEPENDS = "directfb"
-SECTION = "devel/examples"
+SECTION = "libs"
LICENSE = "GPL"
-SRC_URI = "http://www.directfb.org/downloads/Extras/DirectFB-examples-${PV}.tar.gz"
-S = "${WORKDIR}/DirectFB-examples-${PV}"
+SRC_URI = "http://www.directfb.org/downloads/Extras/DirectFB-extra-${PV}.tar.gz"
+S = "${WORKDIR}/DirectFB-extra-${PV}"
inherit autotools
@@ -13,3 +13,8 @@ do_configure_append() {
find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
}
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/packages/directfb/directfb_1.0.0.bb b/packages/directfb/directfb_1.0.0.bb
index caa8dbee8f..669ed49283 100644
--- a/packages/directfb/directfb_1.0.0.bb
+++ b/packages/directfb/directfb_1.0.0.bb
@@ -7,7 +7,7 @@ SECTION = "libs"
LICENSE = "LGPL"
HOMEPAGE = "http://directfb.org"
DEPENDS = "jpeg libpng freetype zlib tslib"
-PR = "r4"
+PR = "r5"
RV = "1.0-0"
SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz \
@@ -38,18 +38,18 @@ do_install() {
FILES_directfb-dbg_append = " ${libdir}/directfb-${RV}/*/*/.debug/*.so \
- ${libdir}/directfb-${RV}/*/.debug/*.so \
- "
+ ${libdir}/directfb-${RV}/*/.debug/*.so \
+"
FILES_directfb-dev_append = " ${libdir}/directfb-${RV}/systems/*.la \
${libdir}/directfb-${RV}/inputdrivers/*.la \
${libdir}/directfb-${RV}/interfaces/*/*.la \
- ${libdir}/directfb-${RV}/wm/*.la"
-
+ ${libdir}/directfb-${RV}/wm/*.la \
+"
FILES_directfb_append = " ${libdir}/directfb-${RV}/systems/*.so \
${libdir}/directfb-${RV}/inputdrivers/*.so \
${libdir}/directfb-${RV}/interfaces/*/*.so \
${libdir}/directfb-${RV}/wm/*.so \
${datadir}/directfb-1.0.0 \
- "
+"
diff --git a/packages/directfb/files/fix-includes.patch b/packages/directfb/files/fix-includes.patch
index 0c40cdb3a6..7b4a112582 100644
--- a/packages/directfb/files/fix-includes.patch
+++ b/packages/directfb/files/fix-includes.patch
@@ -1,7 +1,7 @@
#
# pkgconfig points to STAGING_INCDIR, hence
-# we need to append a directfb/ to make it
-# find its header files
+# we need to make this a local include
+# or else it doesn't find its own header files
#
# Signed-Off: mickey@openmoko.org
#
@@ -14,11 +14,11 @@ Index: DirectFB-1.0.0/include/directfb.h
#define __DIRECTFB_H__
-#include <dfb_types.h>
-+#include <directfb/dfb_types.h>
++#include "dfb_types.h"
#include <sys/time.h> /* struct timeval */
-#include <directfb_keyboard.h>
-+#include <directfb/directfb_keyboard.h>
++#include "directfb_keyboard.h"
#ifdef __cplusplus
extern "C"
diff --git a/packages/directfb/files/fix-pkgconfig-specs.patch b/packages/directfb/files/fix-pkgconfig-specs.patch
index 0273b58ec5..c252dc1792 100644
--- a/packages/directfb/files/fix-pkgconfig-specs.patch
+++ b/packages/directfb/files/fix-pkgconfig-specs.patch
@@ -1,43 +1,48 @@
-diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
---- DirectFB-1.0.0~org/directfb-internal.pc.in 2003-07-04 13:30:22.000000000 -0400
-+++ DirectFB-1.0.0/directfb-internal.pc.in 2007-03-16 22:34:17.000000000 -0400
-@@ -8,4 +8,4 @@
+Index: DirectFB-1.0.0/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/directfb-internal.pc.in
++++ DirectFB-1.0.0/directfb-internal.pc.in
+@@ -8,4 +8,4 @@ Name: DirectFB-Internal
Description: Third party module support package for DirectFB.
Version: @VERSION@
Requires: directfb = @VERSION@
-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
-+Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}
-diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
---- DirectFB-1.0.0~org/directfb.pc.in 2004-08-04 12:28:20.000000000 -0400
-+++ DirectFB-1.0.0/directfb.pc.in 2007-03-16 22:31:33.000000000 -0400
-@@ -8,4 +8,4 @@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir} -I${includedir}/../directfb
+Index: DirectFB-1.0.0/directfb.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/directfb.pc.in
++++ DirectFB-1.0.0/directfb.pc.in
+@@ -8,4 +8,4 @@ Description: Graphics and windowing libr
Version: @VERSION@
Requires: fusion direct
Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
+Cflags: @THREADFLAGS@ -I${includedir}
-diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
---- DirectFB-1.0.0~org/lib/direct/direct.pc.in 2005-11-23 09:18:59.000000000 -0500
-+++ DirectFB-1.0.0/lib/direct/direct.pc.in 2007-03-16 22:32:13.000000000 -0400
-@@ -7,4 +7,4 @@
+Index: DirectFB-1.0.0/lib/direct/direct.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/direct/direct.pc.in
++++ DirectFB-1.0.0/lib/direct/direct.pc.in
+@@ -7,4 +7,4 @@ Name: Direct
Description: DirectFB base development library
Version: @VERSION@
Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
+Cflags: @THREADFLAGS@ -I${includedir}
-diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
---- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in 2004-05-19 07:30:56.000000000 -0400
-+++ DirectFB-1.0.0/lib/fusion/fusion.pc.in 2007-03-16 22:32:34.000000000 -0400
-@@ -8,4 +8,4 @@
+Index: DirectFB-1.0.0/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/fusion/fusion.pc.in
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in
+@@ -8,4 +8,4 @@ Description: High Level IPC Mechanisms
Version: @VERSION@
Requires: direct
Libs: -L${libdir} -lfusion
-Cflags: -I@INCLUDEDIR@
+Cflags: -I${includedir}
-diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
---- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in 2004-05-19 07:31:28.000000000 -0400
-+++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in 2007-03-16 22:32:55.000000000 -0400
-@@ -8,4 +8,4 @@
+Index: DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/voodoo/voodoo.pc.in
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+@@ -8,4 +8,4 @@ Description: Interface based network tra
Version: @VERSION@
Requires: direct
Libs: -L${libdir} -lvoodoo
diff --git a/packages/directfb/fusionsound_0.9.26+cvs20070207.bb b/packages/directfb/fusionsound_0.9.26+cvs20070207.bb
deleted file mode 100644
index fe04a195c1..0000000000
--- a/packages/directfb/fusionsound_0.9.26+cvs20070207.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-DESCRIPTION = "FusionSound for DirectFB"
-DEPENDS = "directfb"
-SECTION = "libs"
-LICENSE = "LGPL"
-
-# this is a CVS only release
-
-SRC_URI = "cvs://anonymous@cvs.directfb.org/cvs/directfb;method=pserver;module=FusionSound;date=${@bb.data.getVar('PV', d, 1)[9:]}"
-
-S = "${WORKDIR}/FusionSound"
-
-inherit autotools pkgconfig
-
-do_configure_append() {
- find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
-}
-
-do_stage() {
- autotools_stage_all
-}
-
-do_install() {
- oe_runmake 'DESTDIR=${D}' install
-}
-
-FILES_fusionsound-dbg_append = " ${libdir}/directfb-1.0-0/*/*/.debug/*.so \
- ${libdir}/directfb-1.0-0/*/.debug/*.so \
- "
-
-FILES_fusionsound-dev_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.la \
- ${libdir}/directfb-1.0-0/snddrivers/*.la \
- "
-
-FILES_fusionsound_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.so \
- ${libdir}/directfb-1.0-0/snddrivers/*.so \
- "
-
diff --git a/packages/directfb/fusionsound_1.0.0.bb b/packages/directfb/fusionsound_1.0.0.bb
new file mode 100644
index 0000000000..3cd4a385f6
--- /dev/null
+++ b/packages/directfb/fusionsound_1.0.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "FusionSound for DirectFB"
+DEPENDS = "directfb libmad libvorbis"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.directfb.org/downloads/Core/FusionSound-${PV}.tar.gz"
+S = "${WORKDIR}/FusionSound-${PV}"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}/directfb:g'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_${PN} += "\
+ ${libdir}/directfb-1.0-0/interfaces/*/*.so \
+ ${libdir}/directfb-1.0-0/snddrivers/*.so \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/directfb-1.0-0/*/*/.debug/*.so \
+ ${libdir}/directfb-1.0-0/*/.debug/*.so \
+"
+
+FILES_${PN}-dev += "\
+ ${libdir}/directfb-1.0-0/interfaces/*/*.la \
+ ${libdir}/directfb-1.0-0/snddrivers/*.la \
+"
+