aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dosfstools
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-07-12 09:03:16 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-12 09:03:16 +0000
commitdb8aa78f3e254ca792b4d9487988c9ff2aacfdc8 (patch)
tree7fb1ecf8a46591910e9afe1f0306c66e103553da /packages/dosfstools
parentd5b6fafb7f5cb67028fe4e92dd6a6b9dc7a359ef (diff)
downloadopenembedded-db8aa78f3e254ca792b4d9487988c9ff2aacfdc8.tar.gz
dosfstools/dosfstools-native 2.10: Fix for lib headers which don't pull in
the types that dosfstools expects such as those provided with Fedora Core 4 and 5. The mkdsofs.c program is using types of the style __u8 which it implictly gets via an include of linux/hdreg.h with some version of libc headers. Explicity include linux/types.h to ensure we get those defines directly. Resolves bug #1155.
Diffstat (limited to 'packages/dosfstools')
-rw-r--r--packages/dosfstools/dosfstools-native_2.10.bb5
-rw-r--r--packages/dosfstools/dosfstools_2.10.bb5
-rw-r--r--packages/dosfstools/files/include-linux-types.patch17
3 files changed, 23 insertions, 4 deletions
diff --git a/packages/dosfstools/dosfstools-native_2.10.bb b/packages/dosfstools/dosfstools-native_2.10.bb
index 78dde3e5e3..01aaae6aa4 100644
--- a/packages/dosfstools/dosfstools-native_2.10.bb
+++ b/packages/dosfstools/dosfstools-native_2.10.bb
@@ -7,7 +7,7 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dosfstools-${PV}"
S="${WORKDIR}/dosfstools-${PV}"
-PR="r2"
+PR="r3"
SRC_URI = "ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/dosfstools-${PV}.src.tar.gz \
file://mkdosfs-bootcode.patch;patch=1 \
@@ -15,7 +15,8 @@ SRC_URI = "ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/dosfstools-${PV}
file://alignment_hack.patch;patch=1 \
file://dosfstools-2.10-kernel-2.6.patch;patch=1 \
file://msdos_fat12_undefined.patch;patch=1 \
- file://dosfstools-msdos_fs-types.patch;patch=1"
+ file://dosfstools-msdos_fs-types.patch;patch=1 \
+ file://include-linux-types.patch;patch=1"
inherit native
diff --git a/packages/dosfstools/dosfstools_2.10.bb b/packages/dosfstools/dosfstools_2.10.bb
index a683e4846b..ec06ae94fc 100644
--- a/packages/dosfstools/dosfstools_2.10.bb
+++ b/packages/dosfstools/dosfstools_2.10.bb
@@ -9,12 +9,13 @@ SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/dosfstools-${PV}.src.tar.gz \
file://alignment_hack.patch;patch=1 \
file://dosfstools-2.10-kernel-2.6.patch;patch=1 \
- file://msdos_fat12_undefined.patch;patch=1"
+ file://msdos_fat12_undefined.patch;patch=1 \
+ file://include-linux-types.patch;patch=1"
do_install () {
oe_runmake "PREFIX=${D}" "SBINDIR=${D}${sbindir}" \
diff --git a/packages/dosfstools/files/include-linux-types.patch b/packages/dosfstools/files/include-linux-types.patch
new file mode 100644
index 0000000000..4bbd4e76e4
--- /dev/null
+++ b/packages/dosfstools/files/include-linux-types.patch
@@ -0,0 +1,17 @@
+mkdsofs is using types of the style __u8, which it gets with some
+versions of libc headers via linux/hdreg.h including asm/types.h.
+Newer version of fedora (at least) have a hdreg.h whichdoes not
+include asm/types.h. To work around this patch mkdosfs.c to explicity
+include linux/types.h which will in turn pull in asm/types.h which
+defines these variables.
+
+--- dosfstools-2.10/mkdosfs/mkdosfs.c~ 2006-07-12 18:46:21.000000000 +1000
++++ dosfstools-2.10/mkdosfs/mkdosfs.c 2006-07-12 18:46:21.000000000 +1000
+@@ -60,6 +60,7 @@
+ #include "../version.h"
+
+ #include <fcntl.h>
++#include <linux/types.h>
+ #include <linux/hdreg.h>
+ #include <linux/fs.h>
+ #include <linux/fd.h>