aboutsummaryrefslogtreecommitdiffstats
path: root/packages/driftnet
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/driftnet
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/driftnet')
-rw-r--r--packages/driftnet/.mtn2git_empty (renamed from packages/driftnet/driftnet-0.1.6/Makefile.orig)0
-rw-r--r--packages/driftnet/driftnet-0.1.6/.mtn2git_empty0
-rw-r--r--packages/driftnet/driftnet-0.1.6/Makefile114
-rw-r--r--packages/driftnet/driftnet-0.1.6/arm.patch55
-rw-r--r--packages/driftnet/driftnet-nogui-0.1.6/.mtn2git_empty0
-rw-r--r--packages/driftnet/driftnet-nogui-0.1.6/arm.patch55
-rw-r--r--packages/driftnet/driftnet-nogui-0.1.6/arm.patch.old49
7 files changed, 273 insertions, 0 deletions
diff --git a/packages/driftnet/driftnet-0.1.6/Makefile.orig b/packages/driftnet/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/driftnet/driftnet-0.1.6/Makefile.orig
+++ b/packages/driftnet/.mtn2git_empty
diff --git a/packages/driftnet/driftnet-0.1.6/.mtn2git_empty b/packages/driftnet/driftnet-0.1.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/driftnet/driftnet-0.1.6/.mtn2git_empty
diff --git a/packages/driftnet/driftnet-0.1.6/Makefile b/packages/driftnet/driftnet-0.1.6/Makefile
index e69de29bb2..62684fd3bf 100644
--- a/packages/driftnet/driftnet-0.1.6/Makefile
+++ b/packages/driftnet/driftnet-0.1.6/Makefile
@@ -0,0 +1,114 @@
+#
+# Makefile:
+# Makefile for driftnet.
+#
+# Copyright (c) 2001 Chris Lightfoot. All rights reserved.
+# Email: chris@ex-parrot.com; WWW: http://www.ex-parrot.com/~chris/
+#
+# $Id: Makefile,v 1.34 2002/07/09 17:30:42 chris Exp $
+#
+
+#
+# User-serviceable parts:
+#
+
+# Compiler to use.
+CC = arm-linux-gcc
+
+# Basic compiler, linker flags; should not need any changes.
+CFLAGS += -g -Wall
+LDFLAGS += -g
+
+# You might need these if libpcap is installed somewhere random.
+#CFLAGS += -I/usr/include/pcap
+#LDFLAGS += -L/path/to/libpcap.so
+
+# Required on Linux to get BSDish definitions of the TCP/IP structs.
+CFLAGS += -D_BSD_SOURCE
+
+# We always need the pcap and pthread libraries.
+LDLIBS += -lpcap -lpthread
+
+# Optional C compiler and linker flags. Typical driftnet builds have support
+# for displaying captured images in an X window, and need the following flags:
+CFLAGS += -I$(STAGING_INCDIR)/glib-2.0 -I$(STAGING_INCDIR)/gtk-2.0 -I$(STAGING_INCDIR)/../lib/gtk-2.0/include -I$(STAGING_INCDIR)/atk-1.0
+LDLIBS += -ljpeg -lungif -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm
+
+# Alternatively, you can build a version of driftnet which can only be used
+# in `adjunct' mode as the back end for some other image-processing program. To
+# use this, comment out the two preceding CFLAGS and LDLIBS lines and uncomment
+# the following line:
+#CFLAGS += -DNO_DISPLAY_WINDOW
+
+# On systems with a C99 compiler, driftnet will use <stdint.h> for the
+# definitions of types such as uint8_t. On other systems like Solaris, these
+# are in <sys/types.h>, and you should uncomment this line.
+#CFLAGS += -DUSE_SYS_TYPES_H
+
+# On Solaris, it is necessary to link against -lposix4 for the definition of
+# nanosleep; uncomment the below.
+#LDLIBS += -lposix4
+
+# added 20020604 edobbs
+# On BSD systems, may need to use /usr/local/include
+#CFLAGS += -I/usr/local/include
+
+
+#
+# No user-serviceable parts below this point.
+#
+
+# Driftnet version.
+VERSION = 0.1.6
+CFLAGS += -DDRIFTNET_VERSION='"$(VERSION)"'
+
+SUBDIRS =
+
+TXTS = README TODO COPYING CHANGES CREDITS driftnet.1 driftnet.1.in endian.c
+SRCS = audio.c mpeghdr.c gif.c img.c jpeg.c png.c driftnet.c image.c \
+ display.c playaudio.c connection.c media.c
+HDRS = img.h driftnet.h mpeghdr.h
+BINS = driftnet
+
+OBJS = $(SRCS:.c=.o)
+
+default: driftnet driftnet.1
+
+driftnet: depend $(OBJS)
+ $(CC) -o driftnet $(OBJS) $(LDFLAGS) $(LDLIBS)
+
+driftnet.1: driftnet.1.in Makefile
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+endianness: endian
+
+
+endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+
+%.o: %.c Makefile endianness
+ $(CC) $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -c -o $@ $<
+
+clean: nodepend
+ rm -f *~ *.bak *.o core $(BINS) TAGS driftnet.1 endian endianness
+
+tags:
+ etags *.c *.h
+
+tarball: nodepend $(SRCS) $(HDRS) $(TXTS)
+ mkdir driftnet-$(VERSION)
+ set -e ; for i in Makefile $(SRCS) $(HDRS) $(TXTS) ; do cp $$i driftnet-$(VERSION)/$$i ; done
+ tar cvzf driftnet-$(VERSION).tar.gz driftnet-$(VERSION)
+ rm -rf driftnet-$(VERSION)
+ mv driftnet-$(VERSION).tar.gz ..
+
+depend: endianness
+ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+
+nodepend:
+ makedepend -- --
+ rm -f depend Makefile.bak
+
+# DO NOT DELETE
diff --git a/packages/driftnet/driftnet-0.1.6/arm.patch b/packages/driftnet/driftnet-0.1.6/arm.patch
index e69de29bb2..340a6cf186 100644
--- a/packages/driftnet/driftnet-0.1.6/arm.patch
+++ b/packages/driftnet/driftnet-0.1.6/arm.patch
@@ -0,0 +1,55 @@
+--- driftnet-0.1.6/Makefile~ 2004-12-07 23:26:53.211878920 +0000
++++ driftnet-0.1.6/Makefile 2004-12-07 23:25:59.900983408 +0000
+@@ -13,14 +13,14 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+ LDFLAGS += -g
+
+ # You might need these if libpcap is installed somewhere random.
+-CFLAGS += -I/usr/include/pcap
++#CFLAGS += -I/usr/include/pcap
+ #LDFLAGS += -L/path/to/libpcap.so
+
+ # Required on Linux to get BSDish definitions of the TCP/IP structs.
+@@ -31,8 +31,8 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++CFLAGS += -I$(STAGING_INCDIR)/glib-2.0 -I$(STAGING_INCDIR)/gtk-2.0 -I$(STAGING_INCDIR)/../lib/gtk-2.0/include -I$(STAGING_INCDIR)/atk-1.0
++LDLIBS += -ljpeg -lungif -lgtk-x11-2.0 -lgdk-x11-2.0 -rdynamic -lgmodule-2.0 -lglib-2.0 -ldl -lXext -lX11 -lm
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+@@ -81,13 +81,13 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+
+ %.o: %.c Makefile endianness
+- $(CC) $(CFLAGS) `cat endianness` -c -o $@ $<
++ $(CC) $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -c -o $@ $<
+
+ clean: nodepend
+ rm -f *~ *.bak *.o core $(BINS) TAGS driftnet.1 endian endianness
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+
diff --git a/packages/driftnet/driftnet-nogui-0.1.6/.mtn2git_empty b/packages/driftnet/driftnet-nogui-0.1.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/driftnet/driftnet-nogui-0.1.6/.mtn2git_empty
diff --git a/packages/driftnet/driftnet-nogui-0.1.6/arm.patch b/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
index e69de29bb2..ebb5fadd7c 100644
--- a/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
+++ b/packages/driftnet/driftnet-nogui-0.1.6/arm.patch
@@ -0,0 +1,55 @@
+--- driftnet-0.1.6/Makefile~ 2002-07-09 19:26:41.000000000 +0000
++++ driftnet-0.1.6/Makefile 2004-10-20 21:51:48.000000000 +0000
+@@ -13,14 +13,14 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+ LDFLAGS += -g
+
+ # You might need these if libpcap is installed somewhere random.
+-CFLAGS += -I/usr/include/pcap
++#CFLAGS += -I/usr/include/pcap
+ #LDFLAGS += -L/path/to/libpcap.so
+
+ # Required on Linux to get BSDish definitions of the TCP/IP structs.
+@@ -31,14 +31,14 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++#CFLAGS += `gtk-config --cflags`
++#LDLIBS += -ljpeg -lungif `gtk-config --libs`
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+ # use this, comment out the two preceding CFLAGS and LDLIBS lines and uncomment
+ # the following line:
+-#CFLAGS += -DNO_DISPLAY_WINDOW
++CFLAGS += -DNO_DISPLAY_WINDOW
+
+ # On systems with a C99 compiler, driftnet will use <stdint.h> for the
+ # definitions of types such as uint8_t. On other systems like Solaris, these
+@@ -81,7 +81,7 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+
diff --git a/packages/driftnet/driftnet-nogui-0.1.6/arm.patch.old b/packages/driftnet/driftnet-nogui-0.1.6/arm.patch.old
index e69de29bb2..fe0f08923c 100644
--- a/packages/driftnet/driftnet-nogui-0.1.6/arm.patch.old
+++ b/packages/driftnet/driftnet-nogui-0.1.6/arm.patch.old
@@ -0,0 +1,49 @@
+--- ./driftnet-0.1.6/Makefile~ 2002-07-09 19:26:41.000000000 +0000
++++ ./driftnet-0.1.6/Makefile 2004-10-16 11:33:48.238088984 +0000
+@@ -13,7 +13,7 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+@@ -31,8 +31,8 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++#CFLAGS += `gtk-config --cflags`
++#LDLIBS += -ljpeg -lungif `gtk-config --libs`
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+@@ -43,7 +43,7 @@
+ # On systems with a C99 compiler, driftnet will use <stdint.h> for the
+ # definitions of types such as uint8_t. On other systems like Solaris, these
+ # are in <sys/types.h>, and you should uncomment this line.
+-#CFLAGS += -DUSE_SYS_TYPES_H
++CFLAGS += -DUSE_SYS_TYPES_H
+
+ # On Solaris, it is necessary to link against -lposix4 for the definition of
+ # nanosleep; uncomment the below.
+@@ -81,7 +81,7 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+