aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ecj/ecj-initial.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-09-23 05:10:26 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-09-23 05:10:26 +0000
commit7afb7925a28564351334c1faac834ae490c32888 (patch)
treed8ce608964e1539c5ebfeb6ccd0034afd47274cf /packages/ecj/ecj-initial.bb
parentb18add6e1ca17aba2a5ee987c6ee14fa4f5db1a0 (diff)
downloadopenembedded-7afb7925a28564351334c1faac834ae490c32888.tar.gz
Part 2 (last one) of ecj rework
ecj-bootstrap-native: New recipe (ommitted version by purpose). ecj-initial: New recipe (ommitted version by purpose). libecj-boostrap: New recipes (3.3, 3.3.2, 3.4)
Diffstat (limited to 'packages/ecj/ecj-initial.bb')
-rw-r--r--packages/ecj/ecj-initial.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/ecj/ecj-initial.bb b/packages/ecj/ecj-initial.bb
new file mode 100644
index 0000000000..106453691b
--- /dev/null
+++ b/packages/ecj/ecj-initial.bb
@@ -0,0 +1,31 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+
+# This variant runs on the initial (not Java5-compatible runtime).
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+LICENSE = "EPL"
+
+DEPENDS = "libecj-bootstrap"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+inherit native
+
+JAR = "ecj-bootstrap.jar"
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-initial
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
+ echo "RUNTIME=java-initial" >> ecj-initial
+ cat ecj.in >> ecj-initial
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
+}