aboutsummaryrefslogtreecommitdiffstats
path: root/packages/efl++
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-17 22:12:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-17 22:12:53 +0000
commitb9bcfe56927ea14b91cc767a82d00ed6a819b281 (patch)
treeba6c9d02ac846a8eb8050499be6b58977fc2d3ed /packages/efl++
parent57142a6c224e8f62cc6a58589fe1334e92593021 (diff)
downloadopenembedded-b9bcfe56927ea14b91cc767a82d00ed6a819b281.tar.gz
efl++: make 0.1.0 build, remove obsolete 0.0.5
Diffstat (limited to 'packages/efl++')
-rw-r--r--packages/efl++/efl++-fb_0.0.5.bb1
-rw-r--r--packages/efl++/efl++-x11_0.0.5.bb3
-rw-r--r--packages/efl++/efl++.inc6
-rw-r--r--packages/efl++/files/.mtn2git_empty0
-rw-r--r--packages/efl++/files/disable-smart.patch21
-rw-r--r--packages/efl++/files/fix-src.pro.patch15
6 files changed, 40 insertions, 6 deletions
diff --git a/packages/efl++/efl++-fb_0.0.5.bb b/packages/efl++/efl++-fb_0.0.5.bb
deleted file mode 100644
index 713c86eb16..0000000000
--- a/packages/efl++/efl++-fb_0.0.5.bb
+++ /dev/null
@@ -1 +0,0 @@
-include efl++.inc
diff --git a/packages/efl++/efl++-x11_0.0.5.bb b/packages/efl++/efl++-x11_0.0.5.bb
deleted file mode 100644
index d55e149d19..0000000000
--- a/packages/efl++/efl++-x11_0.0.5.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-include efl++.inc
-
-EXTRA_QMAKEVARS_POST += "CONFIG+=eflecorex11"
diff --git a/packages/efl++/efl++.inc b/packages/efl++/efl++.inc
index cc7e615e93..b560826662 100644
--- a/packages/efl++/efl++.inc
+++ b/packages/efl++/efl++.inc
@@ -7,10 +7,12 @@ HOMEPAGE = "http://www.Vanille.de/projects/efl++.html"
DEPENDS = "virtual/evas virtual/ecore edje libsigc++-2.0"
PROVIDES = "virtual/efl++"
-SRC_URI = "http://www.Vanille.de/download/efl/efl++_${PV}.tar.bz2"
+SRC_URI = "http://www.Vanille.de/download/efl/efl++_${PV}.tar.bz2 \
+ file://fix-src.pro.patch;patch=1 \
+ file://disable-smart.patch;patch=1"
S = "${WORKDIR}/efl++-${PV}"
-inherit qmake
+inherit qmake qt4x11
PARALLEL_MAKE = ""
QMAKE_PROFILES = "efl++.pro"
diff --git a/packages/efl++/files/.mtn2git_empty b/packages/efl++/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/efl++/files/.mtn2git_empty
diff --git a/packages/efl++/files/disable-smart.patch b/packages/efl++/files/disable-smart.patch
new file mode 100644
index 0000000000..cdb157cdef
--- /dev/null
+++ b/packages/efl++/files/disable-smart.patch
@@ -0,0 +1,21 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- efl++-0.1.0/src/evas/evas.cpp~disable-smart
++++ efl++-0.1.0/src/evas/evas.cpp
+@@ -7,9 +7,13 @@
+ /* EFL */
+ extern "C" {
+ #include <Edje.h>
++#ifdef EFL_SUPPORT_ESMART
+ #include <Esmart/Esmart_Container.h>
+ #include <Esmart/Esmart_Text_Entry.h>
++#endif
++#ifdef EFL_SUPPORT_EMOTION
+ #include <Emotion.h>
++#endif
+ }
+
+ /* STD */
diff --git a/packages/efl++/files/fix-src.pro.patch b/packages/efl++/files/fix-src.pro.patch
new file mode 100644
index 0000000000..234d38af3d
--- /dev/null
+++ b/packages/efl++/files/fix-src.pro.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- efl++-0.1.0/src/src.pro~fix-src.pro
++++ efl++-0.1.0/src/src.pro
+@@ -30,6 +30,7 @@
+ include ( emotion/emotion.pro )
+ LIBS += -lemotion
+ DEFINES += EFL_SUPPORT_EMOTION
++}
+
+ eflesmart {
+ include ( esmart/esmart.pro )