aboutsummaryrefslogtreecommitdiffstats
path: root/packages/efl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-10 18:03:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-10 18:03:17 +0000
commit57efa75ce8ded5f8f617ef6896b08ee648c7852f (patch)
treedbd189b5836a09f484bd2d0f6976b82a42db187d /packages/efl
parent57e9d2faad832e99be6b1ba6cbe9e743b5b99e3d (diff)
downloadopenembedded-57efa75ce8ded5f8f617ef6896b08ee648c7852f.tar.gz
E: commit missing files
Diffstat (limited to 'packages/efl')
-rw-r--r--packages/efl/engrave_20050810.bb16
-rw-r--r--packages/efl/evas/.mtn2git_empty0
-rw-r--r--packages/efl/evas/fix-configure.patch49
3 files changed, 65 insertions, 0 deletions
diff --git a/packages/efl/engrave_20050810.bb b/packages/efl/engrave_20050810.bb
new file mode 100644
index 0000000000..13e68259a9
--- /dev/null
+++ b/packages/efl/engrave_20050810.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Engrave is an Edje Editing Library"
+LICENSE = "MIT"
+DEPENDS = "jpeg edb ecore-x11 evas-x11 edje imlib2-x11"
+
+inherit efl
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/libs/engrave"
+S = "${WORKDIR}/engrave"
+
+do_stage_append() {
+ for i in src/lib/engrave*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}
+
diff --git a/packages/efl/evas/.mtn2git_empty b/packages/efl/evas/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/efl/evas/.mtn2git_empty
diff --git a/packages/efl/evas/fix-configure.patch b/packages/efl/evas/fix-configure.patch
new file mode 100644
index 0000000000..cc7462e72c
--- /dev/null
+++ b/packages/efl/evas/fix-configure.patch
@@ -0,0 +1,49 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- evas-0.9.9.013/configure.in~fix-configure
++++ evas-0.9.9.013/configure.in
+@@ -157,9 +157,7 @@
+ [
+ AM_CONDITIONAL(BUILD_ENGINE_SOFTWARE_X11, true)
+ AC_DEFINE(BUILD_ENGINE_SOFTWARE_X11, 1, [Software X11 Rendering Backend])
+- x_dir=${x_dir:-/usr/X11R6}
+- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
+- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
++ x_libs="-lX11 -lXext";
+ ENGINE_SOFTWARE_X11_PRG="evas_software_x11_test evas_software_x11_perf_test evas_software_x11_perf_load"
+ ],
+ [
+@@ -221,7 +219,7 @@
+ X11/X.h,
+ [AM_CONDITIONAL(BUILD_ENGINE_SOFTWARE_XCB, true)
+ AC_DEFINE(BUILD_ENGINE_SOFTWARE_XCB, 1, [Software XCB Rendering Backend])
+- xcb_dir=${x_dir:-/usr/X11R6}
++ xcb_dir=${x_dir:-}
+ xcb_cflags="${x_cflags:--I${x_includes:-$x_dir/include}} $XCB_CFLAGS $XCB_ICCCM_CFLAGS"
+ xcb_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} $XCB_LIBS $XCB_ICCCM_LIBS"
+ ENGINE_SOFTWARE_XCB_PRG="evas_software_xcb_test evas_software_xcb_perf_test evas_software_xcb_perf_load"],
+@@ -433,10 +431,10 @@
+ AC_DEFINE(BUILD_ENGINE_GL_X11, 1, [OpenGL X11 Rendering Backend])
+ AM_CONDITIONAL(BUILD_ENGINE_GL_COMMON, true)
+ AC_DEFINE(BUILD_ENGINE_GL_COMMON, 1, [Generic OpenGL Rendering Support])
+- x_dir=${x_dir:-/usr/X11R6};
++ x_dir=${x_dir:-};
+ x_cflags=${x_cflags:--I$x_dir/include}
+ x_libs="${x_libs:--L$x_dir/lib -lX11 -lXext}"
+- gl_cflags="-I/usr/include"
++ gl_cflags=""
+ gl_libs="-lGL -lGLU -lpthread"
+ gl_dir=""
+ ENGINE_GL_X11_PRG="evas_gl_x11_test"
+@@ -490,7 +488,7 @@
+ AC_DEFINE(BUILD_ENGINE_CAIRO_X11, 1, [Cairo X11 Rendering Backend])
+ AM_CONDITIONAL(BUILD_ENGINE_CAIRO_COMMON, true)
+ AC_DEFINE(BUILD_ENGINE_CAIRO_COMMON, 1, [Generic Cairo Rendering Support])
+- x_dir="/usr/X11R6";
++ x_dir="";
+ x_cflags="-I"$x_dir"/include"
+ x_libs="-L"$x_dir"/lib -lX11 -lXext"
+ ENGINE_CAIRO_X11_PRG="evas_cairo_x11_test"