aboutsummaryrefslogtreecommitdiffstats
path: root/packages/elitaire
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-08-22 20:50:10 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-22 20:50:10 +0000
commit15327f6dce227ddd18ac4a0da40ffe72e509df0d (patch)
tree9789f3625211fb78d8ce0f4d079042ecf3be3cf2 /packages/elitaire
parent2ec8b2daa238174a06c025c2a69cd96dd0fa6bcf (diff)
downloadopenembedded-15327f6dce227ddd18ac4a0da40ffe72e509df0d.tar.gz
Add elitaire, an EFL based card game playing program
Diffstat (limited to 'packages/elitaire')
-rw-r--r--packages/elitaire/.mtn2git_empty0
-rw-r--r--packages/elitaire/elitaire_0.0.4.bb12
-rw-r--r--packages/elitaire/files/.mtn2git_empty0
-rw-r--r--packages/elitaire/files/fix-ewl-and-gettext.patch37
4 files changed, 49 insertions, 0 deletions
diff --git a/packages/elitaire/.mtn2git_empty b/packages/elitaire/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/elitaire/.mtn2git_empty
diff --git a/packages/elitaire/elitaire_0.0.4.bb b/packages/elitaire/elitaire_0.0.4.bb
new file mode 100644
index 0000000000..220b6ace16
--- /dev/null
+++ b/packages/elitaire/elitaire_0.0.4.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "EFL-based solitaire"
+DEPENDS = "evas-x11 ecore-x11 edje esmart ewl"
+LICENSE = "MIT"
+SECTION = "e/apps"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r0"
+
+SRC_URI = "http://www.mowem.de/elitaire/elitaire-0.0.4.tar.bz2 \
+ file://fix-ewl-and-gettext.patch;patch=1"
+
+inherit autotools pkgconfig binconfig
+
diff --git a/packages/elitaire/files/.mtn2git_empty b/packages/elitaire/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/elitaire/files/.mtn2git_empty
diff --git a/packages/elitaire/files/fix-ewl-and-gettext.patch b/packages/elitaire/files/fix-ewl-and-gettext.patch
new file mode 100644
index 0000000000..f84ec06d34
--- /dev/null
+++ b/packages/elitaire/files/fix-ewl-and-gettext.patch
@@ -0,0 +1,37 @@
+diff -Nur elitaire-0.0.4~/src/Eli_App.h elitaire-0.0.4/src/Eli_App.h
+--- elitaire-0.0.4~/src/Eli_App.h 2005-08-18 19:02:30.000000000 -0700
++++ elitaire-0.0.4/src/Eli_App.h 2005-08-18 19:02:40.000000000 -0700
+@@ -3,7 +3,7 @@
+ #include<Ecore_Config.h>
+ #include<Ecore_File.h>
+ #include<Esmart/Esmart_Container.h>
+-#include<ewl/Ewl.h>
++#include<Ewl.h>
+ #include"ewl_context_menu.h"
+ #include"Elitaire.h"
+
+diff -Nur elitaire-0.0.4~/src/ewl_context_menu.c elitaire-0.0.4/src/ewl_context_menu.c
+--- elitaire-0.0.4~/src/ewl_context_menu.c 2005-08-18 19:02:30.000000000 -0700
++++ elitaire-0.0.4/src/ewl_context_menu.c 2005-08-18 19:02:40.000000000 -0700
+@@ -1,4 +1,4 @@
+-#include<ewl/Ewl.h>
++#include<Ewl.h>
+ #include"ewl_context_menu.h"
+
+ void ewl_context_menu_expand_cb(Ewl_Widget *w, void *ev_data ,
+diff -Nur elitaire-0.0.4~/src/intl.h elitaire-0.0.4/src/intl.h
+--- elitaire-0.0.4~/src/intl.h 2005-08-18 19:02:30.000000000 -0700
++++ elitaire-0.0.4/src/intl.h 2005-08-18 19:06:05.000000000 -0700
+@@ -13,8 +13,12 @@
+
+ inline char * sgettext(const char *msgid)
+ {
++#ifdef ENABLE_NLS
+ char *msgval = gettext (msgid);
+ if (msgval == msgid)
++#else
++ char *msgval;
++#endif
+ msgval = strrchr (msgid, '|') + 1;
+ return msgval;
+ }