aboutsummaryrefslogtreecommitdiffstats
path: root/packages/elitaire
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-30 17:59:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 17:59:20 +0000
commit7e5e0be1af62584244662daa1989ffd8206c7298 (patch)
tree6eade7dca695f1668a509a7debde9aae887b9ff0 /packages/elitaire
parent206647fb6ccf68137a2793c913053579f4553244 (diff)
downloadopenembedded-7e5e0be1af62584244662daa1989ffd8206c7298.tar.gz
e17, efl: major upgrade to newer versions
- Upgraded shapshot-based packages to newest released snapshots - Upgraded CVS-based packages to use a newer date - Moved e and e-wm to use snapshots as a default instead of CVS - Updated patches to work with newer versions - Added patches to fix problems introduced in newer versions - Added a patch to disable the splash for e-wm (causes a segfault) - entrance now uses ecore_config instead of edb - Added pulling of m4 directories for a few packages and running of aclocal due to autotools problems - elitaire currently does not compile, removed from e-image
Diffstat (limited to 'packages/elitaire')
-rw-r--r--packages/elitaire/elitaire_0.0.5.bb (renamed from packages/elitaire/elitaire_0.0.4.bb)5
-rw-r--r--packages/elitaire/files/fix-ewl-and-gettext.patch21
-rw-r--r--packages/elitaire/files/math.patch14
3 files changed, 17 insertions, 23 deletions
diff --git a/packages/elitaire/elitaire_0.0.4.bb b/packages/elitaire/elitaire_0.0.5.bb
index 5891fba9ae..ac3aebebbf 100644
--- a/packages/elitaire/elitaire_0.0.4.bb
+++ b/packages/elitaire/elitaire_0.0.5.bb
@@ -5,8 +5,9 @@ SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
PR = "r0"
-SRC_URI = "http://www.mowem.de/elitaire/elitaire-0.0.4.tar.bz2 \
- file://fix-ewl-and-gettext.patch;patch=1"
+SRC_URI = "http://www.mowem.de/elitaire/elitaire-${PV}.tar.bz2 \
+ file://fix-ewl-and-gettext.patch;patch=1 \
+ file://math.patch;patch=1"
inherit autotools pkgconfig binconfig
diff --git a/packages/elitaire/files/fix-ewl-and-gettext.patch b/packages/elitaire/files/fix-ewl-and-gettext.patch
index f84ec06d34..f572124f94 100644
--- a/packages/elitaire/files/fix-ewl-and-gettext.patch
+++ b/packages/elitaire/files/fix-ewl-and-gettext.patch
@@ -1,24 +1,3 @@
-diff -Nur elitaire-0.0.4~/src/Eli_App.h elitaire-0.0.4/src/Eli_App.h
---- elitaire-0.0.4~/src/Eli_App.h 2005-08-18 19:02:30.000000000 -0700
-+++ elitaire-0.0.4/src/Eli_App.h 2005-08-18 19:02:40.000000000 -0700
-@@ -3,7 +3,7 @@
- #include<Ecore_Config.h>
- #include<Ecore_File.h>
- #include<Esmart/Esmart_Container.h>
--#include<ewl/Ewl.h>
-+#include<Ewl.h>
- #include"ewl_context_menu.h"
- #include"Elitaire.h"
-
-diff -Nur elitaire-0.0.4~/src/ewl_context_menu.c elitaire-0.0.4/src/ewl_context_menu.c
---- elitaire-0.0.4~/src/ewl_context_menu.c 2005-08-18 19:02:30.000000000 -0700
-+++ elitaire-0.0.4/src/ewl_context_menu.c 2005-08-18 19:02:40.000000000 -0700
-@@ -1,4 +1,4 @@
--#include<ewl/Ewl.h>
-+#include<Ewl.h>
- #include"ewl_context_menu.h"
-
- void ewl_context_menu_expand_cb(Ewl_Widget *w, void *ev_data ,
diff -Nur elitaire-0.0.4~/src/intl.h elitaire-0.0.4/src/intl.h
--- elitaire-0.0.4~/src/intl.h 2005-08-18 19:02:30.000000000 -0700
+++ elitaire-0.0.4/src/intl.h 2005-08-18 19:06:05.000000000 -0700
diff --git a/packages/elitaire/files/math.patch b/packages/elitaire/files/math.patch
new file mode 100644
index 0000000000..550507f370
--- /dev/null
+++ b/packages/elitaire/files/math.patch
@@ -0,0 +1,14 @@
+--- elitaire-0.0.4/src/Elitaire.h~ 2005-08-15 06:32:32.000000000 -0700
++++ elitaire-0.0.4/src/Elitaire.h 2005-09-29 19:19:25.000000000 -0700
+@@ -3,6 +3,11 @@
+ #include<Evas.h>
+ #include<Edje.h>
+ #include"intl.h"
++#include<tgmath.h>
++
++#ifndef ABS
++#define ABS(x) ((x) >= 0 ? (x) : -(x))
++#endif
+
+ struct Elitaire{
+