aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fam
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/fam
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/fam')
-rw-r--r--packages/fam/.mtn2git_empty0
-rw-r--r--packages/fam/fam-2.6.10/.mtn2git_empty0
-rw-r--r--packages/fam/fam-2.6.10/rpcsvc.patch17
-rw-r--r--packages/fam/fam-2.7.0/.mtn2git_empty0
-rw-r--r--packages/fam/fam-2.7.0/compile-fix.patch27
-rw-r--r--packages/fam/fam_2.6.10.bb17
-rw-r--r--packages/fam/fam_2.7.0.bb17
7 files changed, 78 insertions, 0 deletions
diff --git a/packages/fam/.mtn2git_empty b/packages/fam/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fam/.mtn2git_empty
diff --git a/packages/fam/fam-2.6.10/.mtn2git_empty b/packages/fam/fam-2.6.10/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fam/fam-2.6.10/.mtn2git_empty
diff --git a/packages/fam/fam-2.6.10/rpcsvc.patch b/packages/fam/fam-2.6.10/rpcsvc.patch
index e69de29bb2..ce36beb634 100644
--- a/packages/fam/fam-2.6.10/rpcsvc.patch
+++ b/packages/fam/fam-2.6.10/rpcsvc.patch
@@ -0,0 +1,17 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- fam-2.6.10/fam/Makefile.am~rpcsvc 2003-04-15 00:21:26.000000000 -0400
++++ fam-2.6.10/fam/Makefile.am 2004-03-05 10:43:32.000000000 -0500
+@@ -76,7 +76,8 @@
+
+ EXTRA_fam_SOURCES = IMonIrix.c++ IMonLinux.c++ IMonNone.c++
+
+-fam_LDADD = -lrpcsvc $(top_srcdir)/support/libsupport.a
++#fam_LDADD = -lrpcsvc $(top_srcdir)/support/libsupport.a
++fam_LDADD = $(top_srcdir)/support/libsupport.a
+
+ CLEANFILES += @MKDEPFILE@ ii_files/*.ii
+ sinclude @MKDEPFILE@
diff --git a/packages/fam/fam-2.7.0/.mtn2git_empty b/packages/fam/fam-2.7.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fam/fam-2.7.0/.mtn2git_empty
diff --git a/packages/fam/fam-2.7.0/compile-fix.patch b/packages/fam/fam-2.7.0/compile-fix.patch
index e69de29bb2..cb9c702af5 100644
--- a/packages/fam/fam-2.7.0/compile-fix.patch
+++ b/packages/fam/fam-2.7.0/compile-fix.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- fam-2.7.0/src/Listener.c++~compile-fix 2003-01-20 01:37:29.000000000 +0100
++++ fam-2.7.0/src/Listener.c++ 2004-02-28 23:53:57.000000000 +0100
+@@ -45,7 +45,7 @@
+ #include "BTree.h"
+
+ #if !(HAVE_BINDRESVPORT_PROTO)
+-extern "C" int bindresvport(int sd, struct sockaddr_in *);
++extern "C" int bindresvport(int sd, struct sockaddr_in *) throw();
+ #endif
+
+ struct NegotiatingClient
+--- fam-2.7.0/src/Log.c++~compile-fix 2003-01-18 15:18:12.000000000 +0100
++++ fam-2.7.0/src/Log.c++ 2004-02-29 02:23:23.000000000 +0100
+@@ -264,7 +264,7 @@
+ // New back end for assert() will log to syslog, put core file
+ // in known directory.
+
+-void __assert(const char *msg, const char *file, int line)
++void __assert(const char *msg, const char *file, int line) throw()
+ {
+ char *dirname = new char[strlen(Log::getName()) + 20];
+ (void) sprintf(dirname, "/usr/tmp/%s.%d", Log::getName(), getpid());
diff --git a/packages/fam/fam_2.6.10.bb b/packages/fam/fam_2.6.10.bb
index e69de29bb2..60f9ac901e 100644
--- a/packages/fam/fam_2.6.10.bb
+++ b/packages/fam/fam_2.6.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "File Alteration Monitor"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "ftp://oss.sgi.com/projects/fam/download/stable/fam-${PV}.tar.gz \
+ file://rpcsvc.patch;patch=1"
+
+inherit autotools
+
+CPPFLAGS_append = " -DNDEBUG"
+
+do_stage() {
+ oe_libinstall -so -a -C libfam libfam ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/fam.h ${STAGING_INCDIR}/
+}
+
diff --git a/packages/fam/fam_2.7.0.bb b/packages/fam/fam_2.7.0.bb
index e69de29bb2..b3265bbd96 100644
--- a/packages/fam/fam_2.7.0.bb
+++ b/packages/fam/fam_2.7.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "File Alteration Monitor"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "ftp://oss.sgi.com/projects/fam/download/stable/fam-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+
+inherit autotools
+
+CPPFLAGS_append = " -DNDEBUG"
+
+do_stage() {
+ oe_libinstall -so -a -C lib libfam ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/fam.h ${STAGING_INCDIR}/
+}
+