aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fbgrab
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-17 04:50:57 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-17 04:50:57 +0000
commit08b7353bf6d734479988935adaaa0df251fe7525 (patch)
treea0f6ccb105ec6ccd40cfa80aa21ecfcad764217e /packages/fbgrab
parent6f82efe014e940310ef0c1f81d06e7915c8fe7f7 (diff)
downloadopenembedded-08b7353bf6d734479988935adaaa0df251fe7525.tar.gz
add fbgrab-viewer-native
Diffstat (limited to 'packages/fbgrab')
-rw-r--r--packages/fbgrab/fbgrab-viewer-native_1.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/fbgrab/fbgrab-viewer-native_1.0.bb b/packages/fbgrab/fbgrab-viewer-native_1.0.bb
new file mode 100644
index 0000000000..2494918c31
--- /dev/null
+++ b/packages/fbgrab/fbgrab-viewer-native_1.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Viewer for a network enabled fbgrab"
+HOMEPAGE = "http://svn.openezx.org/trunk/src/userspace/fbgrab/"
+LICENSE = "GPL"
+SECTION = "console/network"
+DEPENDS = "libpng-native"
+PV = "0.0+svn${SRCDATE}"
+PR = "r30"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=fbgrab;proto=http"
+S = "${WORKDIR}/fbgrab"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -g -Wall -lpng -lX11 -o fbgrab-viewer fbgrab-viewer.c
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 fbgrab-viewer ${DEPLOY_DIR_IMAGE}/fbgrab-viewer
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_install after do_compile