aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ffmpeg
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-02-24 02:23:16 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-02-24 02:23:16 +0000
commit04ca25a7f9957906c5121005391967de930eb58a (patch)
tree7615d496e9ce83687e96e595170f77be4c5e2bc4 /packages/ffmpeg
parent27ed967384469cb10b308e50e147cf981441d4c2 (diff)
downloadopenembedded-04ca25a7f9957906c5121005391967de930eb58a.tar.gz
ffmpeg: fix 0.4.9-pre1 oebug 1897, fix svn packaging oebug 3850
* gcc4.patch absorbs the original common.patch and adds hacks to satisfy stricter type checking by gcc4 * soname.patch adds libpostproc fix in oebug 1897 comment#1 * drop the obsolete/dup patches in ffmpeg dir * 1st attemp to unify 0.4.9 and svn. * TODO: further unification of packaging and staging is desired once svn recipie settles
Diffstat (limited to 'packages/ffmpeg')
-rw-r--r--packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch13
-rw-r--r--packages/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch146
-rw-r--r--packages/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch36
-rw-r--r--packages/ffmpeg/ffmpeg.inc39
-rw-r--r--packages/ffmpeg/ffmpeg/.mtn2git_empty0
-rw-r--r--packages/ffmpeg/ffmpeg/common.patch13
-rw-r--r--packages/ffmpeg/ffmpeg/configure.patch87
-rw-r--r--packages/ffmpeg/ffmpeg/soname.patch65
-rw-r--r--packages/ffmpeg/ffmpeg_0.4.9-pre1.bb107
-rw-r--r--packages/ffmpeg/ffmpeg_svn.bb60
10 files changed, 273 insertions, 293 deletions
diff --git a/packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch b/packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch
deleted file mode 100644
index 5a1ceaa10d..0000000000
--- a/packages/ffmpeg/ffmpeg-0.4.9-pre1/common.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ffmpeg-0.4.9-pre1/libavcodec/common.h.orig 2004-12-24 23:49:50.000000000 +0100
-+++ ffmpeg-0.4.9-pre1/libavcodec/common.h 2004-12-24 23:51:37.000000000 +0100
-@@ -1292,10 +1292,6 @@
- #define time time_is_forbidden_due_to_security_issues
- #define rand rand_is_forbidden_due_to_state_trashing
- #define srand srand_is_forbidden_due_to_state_trashing
--#if !(defined(LIBAVFORMAT_BUILD) || defined(_FRAMEHOOK_H))
--#define printf please_use_av_log
--#define fprintf please_use_av_log
--#endif
-
- #define CHECKED_ALLOCZ(p, size)\
- {\
diff --git a/packages/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch b/packages/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch
new file mode 100644
index 0000000000..e04fdab3e5
--- /dev/null
+++ b/packages/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch
@@ -0,0 +1,146 @@
+--- ffmpeg-0.4.9-pre1/libavcodec/common.h.orig 2008-02-23 19:42:48.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/common.h 2008-02-23 19:08:09.000000000 -0500
+@@ -64,11 +64,11 @@
+
+ struct AVOption;
+ #ifdef HAVE_MMX
+-extern const struct AVOption avoptions_common[3 + 5];
++extern const struct AVOption *avoptions_common[2 + 5];
+ #else
+-extern const struct AVOption avoptions_common[3];
++extern const struct AVOption *avoptions_common[2];
+ #endif
+-extern const struct AVOption avoptions_workaround_bug[11];
++extern const struct AVOption *avoptions_workaround_bug[10];
+
+ #endif /* HAVE_AV_CONFIG_H */
+
+@@ -1292,10 +1292,6 @@ tend= rdtsc();\
+ #define time time_is_forbidden_due_to_security_issues
+ #define rand rand_is_forbidden_due_to_state_trashing
+ #define srand srand_is_forbidden_due_to_state_trashing
+-#if !(defined(LIBAVFORMAT_BUILD) || defined(_FRAMEHOOK_H))
+-#define printf please_use_av_log
+-#define fprintf please_use_av_log
+-#endif
+
+ #define CHECKED_ALLOCZ(p, size)\
+ {\
+--- ffmpeg-0.4.9-pre1/libavcodec/ac3tab.h.orig 2008-02-23 19:46:06.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/ac3tab.h 2008-02-23 19:08:09.000000000 -0500
+@@ -4,10 +4,10 @@
+ */
+
+ /* possible frequencies */
+-static const uint16_t ac3_freqs[3] = { 48000, 44100, 32000 };
++const uint16_t ac3_freqs[3] = { 48000, 44100, 32000 };
+
+ /* possible bitrates */
+-static const uint16_t ac3_bitratetab[19] = {
++const uint16_t ac3_bitratetab[19] = {
+ 32, 40, 48, 56, 64, 80, 96, 112, 128,
+ 160, 192, 224, 256, 320, 384, 448, 512, 576, 640
+ };
+@@ -15,7 +15,7 @@ static const uint16_t ac3_bitratetab[19]
+ /* AC3 MDCT window */
+
+ /* MDCT window */
+-static const int16_t ac3_window[256] = {
++const int16_t ac3_window[256] = {
+ 4, 7, 12, 16, 21, 28, 34, 42,
+ 51, 61, 72, 84, 97, 111, 127, 145,
+ 164, 184, 207, 231, 257, 285, 315, 347,
+@@ -144,27 +144,27 @@ static const uint8_t baptab[64]= {
+ 15, 15, 15, 15,
+ };
+
+-static const uint8_t sdecaytab[4]={
++const uint8_t sdecaytab[4]={
+ 0x0f, 0x11, 0x13, 0x15,
+ };
+
+-static const uint8_t fdecaytab[4]={
++const uint8_t fdecaytab[4]={
+ 0x3f, 0x53, 0x67, 0x7b,
+ };
+
+-static const uint16_t sgaintab[4]= {
++const uint16_t sgaintab[4]= {
+ 0x540, 0x4d8, 0x478, 0x410,
+ };
+
+-static const uint16_t dbkneetab[4]= {
++const uint16_t dbkneetab[4]= {
+ 0x000, 0x700, 0x900, 0xb00,
+ };
+
+-static const uint16_t floortab[8]= {
++const uint16_t floortab[8]= {
+ 0x2f0, 0x2b0, 0x270, 0x230, 0x1f0, 0x170, 0x0f0, 0xf800,
+ };
+
+-static const uint16_t fgaintab[8]= {
++const uint16_t fgaintab[8]= {
+ 0x080, 0x100, 0x180, 0x200, 0x280, 0x300, 0x380, 0x400,
+ };
+
+--- ffmpeg-0.4.9-pre1/libavcodec/dsputil.h.orig 2008-02-23 19:47:34.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/dsputil.h 2008-02-23 19:08:09.000000000 -0500
+@@ -558,15 +558,15 @@ static int name16(void /*MpegEncContext*
+ /* XXX: add ISOC specific test to avoid specific BSD testing. */
+ /* better than nothing implementation. */
+ /* btw, rintf() is existing on fbsd too -- alex */
+-static inline long int lrintf(float x)
+-{
+-#ifdef CONFIG_WIN32
+- /* XXX: incorrect, but make it compile */
+- return (int)(x);
+-#else
+- return (int)(rint(x));
+-#endif
+-}
++//static inline long int lrintf(float x)
++//{
++//#ifdef CONFIG_WIN32
++// /* XXX: incorrect, but make it compile */
++// return (int)(x);
++//#else
++// return (int)(rint(x));
++//#endif
++//}
+ #else
+ #ifndef _ISOC9X_SOURCE
+ #define _ISOC9X_SOURCE
+--- ffmpeg-0.4.9-pre1/libavcodec/opts.c.orig 2008-02-23 19:49:11.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/opts.c 2008-02-23 19:08:09.000000000 -0500
+@@ -12,7 +12,7 @@
+
+ #include "avcodec.h"
+
+-const AVOption avoptions_common[] = {
++const AVOption *avoptions_common[] = {
+ AVOPTION_CODEC_FLAG("bit_exact", "use only bit-exact stuff", flags, CODEC_FLAG_BITEXACT, 0),
+ AVOPTION_CODEC_FLAG("mm_force", "force mm flags", dsp_mask, FF_MM_FORCE, 0),
+ #ifdef HAVE_MMX
+@@ -22,10 +22,10 @@ const AVOption avoptions_common[] = {
+ AVOPTION_CODEC_FLAG("mm_sse", "mask SSE feature", dsp_mask, FF_MM_SSE, 0),
+ AVOPTION_CODEC_FLAG("mm_sse2", "mask SSE2 feature", dsp_mask, FF_MM_SSE2, 0),
+ #endif
+- AVOPTION_END()
++// AVOPTION_END()
+ };
+
+-const AVOption avoptions_workaround_bug[] = {
++const AVOption *avoptions_workaround_bug[] = {
+ AVOPTION_CODEC_FLAG("bug_autodetect", "workaround bug autodetection", workaround_bugs, FF_BUG_AUTODETECT, 1),
+ AVOPTION_CODEC_FLAG("bug_old_msmpeg4", "workaround old msmpeg4 bug", workaround_bugs, FF_BUG_OLD_MSMPEG4, 0),
+ AVOPTION_CODEC_FLAG("bug_xvid_ilace", "workaround XviD interlace bug", workaround_bugs, FF_BUG_XVID_ILACE, 0),
+@@ -36,7 +36,7 @@ const AVOption avoptions_workaround_bug[
+ AVOPTION_CODEC_FLAG("bug_std_qpel", "workaround std qpel bug", workaround_bugs, FF_BUG_STD_QPEL, 0),
+ AVOPTION_CODEC_FLAG("bug_qpel_chroma2", "workaround qpel chroma2 bug", workaround_bugs, FF_BUG_QPEL_CHROMA2, 0),
+ AVOPTION_CODEC_FLAG("bug_direct_blocksize", "workaround direct blocksize bug", workaround_bugs, FF_BUG_DIRECT_BLOCKSIZE, 0),
+- AVOPTION_END()
++// AVOPTION_END()
+ };
+
+ /* avoid compatibility problems by redefining it */
diff --git a/packages/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch b/packages/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch
index 48de6f01bf..80bf3937e4 100644
--- a/packages/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch
+++ b/packages/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch
@@ -1,6 +1,6 @@
---- ffmpeg-0.4.9-pre1/libavcodec/Makefile.orig 2004-08-25 22:36:39.000000000 +0200
-+++ ffmpeg-0.4.9-pre1/libavcodec/Makefile 2004-08-25 22:37:22.000000000 +0200
-@@ -7,7 +7,7 @@
+--- ffmpeg-0.4.9-pre1/libavcodec/Makefile.orig 2008-02-23 19:34:18.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/Makefile 2008-02-23 19:24:55.000000000 -0500
+@@ -7,7 +7,7 @@ include ../config.mak
VPATH=$(SRC_PATH)/libavcodec
# NOTE: -I.. is needed to include config.h
@@ -9,7 +9,19 @@
OBJS= common.o utils.o mem.o allcodecs.o \
mpegvideo.o jrevdct.o jfdctfst.o jfdctint.o\
-@@ -197,7 +197,7 @@
+@@ -89,9 +89,10 @@ endif
+
+ ifeq ($(CONFIG_PP),yes)
+ ifeq ($(SHARED_PP),yes)
+-EXTRALIBS += -lpostproc
++LIBS += -lpostproc
+ else
+ # LIBS += libpostproc/libpostproc.a ... should be fixed
++LIBS += libpostproc/libpostproc.a
+ OBJS += libpostproc/postprocess.o
+ endif
+ endif
+@@ -197,7 +198,7 @@ ifeq ($(CONFIG_WIN32),yes)
$(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS)
-lib /machine:i386 /def:$(@:.dll=.def)
else
@@ -18,7 +30,7 @@
endif
dsputil.o: dsputil.c dsputil.h
-@@ -269,8 +269,9 @@
+@@ -269,8 +270,9 @@ ifeq ($(CONFIG_WIN32),yes)
install -s -m 755 $(SLIB) "$(prefix)"
else
install -d $(prefix)/lib
@@ -30,10 +42,9 @@
ldconfig || true
endif
else
-
---- ffmpeg-0.4.9-pre1/libavformat/Makefile.orig 2004-08-26 13:45:12.000000000 +0200
-+++ ffmpeg-0.4.9-pre1/libavformat/Makefile 2004-08-26 13:46:00.000000000 +0200
-@@ -6,7 +6,7 @@
+--- ffmpeg-0.4.9-pre1/libavformat/Makefile.orig 2008-02-23 19:37:40.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavformat/Makefile 2008-02-23 19:06:56.000000000 -0500
+@@ -6,7 +6,7 @@ include ../config.mak
VPATH=$(SRC_PATH)/libavformat
@@ -42,7 +53,7 @@
OBJS= utils.o cutils.o os_support.o allformats.o
PPOBJS=
-@@ -54,6 +54,7 @@
+@@ -54,6 +54,7 @@ endif
ifeq ($(CONFIG_AUDIO_BEOS),yes)
PPOBJS+= beosaudio.o
EXTRALIBS+=-lbe -lmedia
@@ -50,7 +61,7 @@
# this should be the default !
EXTRALIBS+=-lavcodec -L../libavcodec
endif
-@@ -93,7 +94,7 @@
+@@ -93,7 +94,7 @@ ifeq ($(CONFIG_WIN32),yes)
$(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) $(VPATH)/../libavcodec/avcodec.dll
-lib /machine:i386 /def:$(@:.dll=.def)
else
@@ -59,7 +70,7 @@
endif
depend: $(SRCS)
-@@ -105,8 +106,9 @@
+@@ -105,8 +106,9 @@ ifeq ($(CONFIG_WIN32),yes)
install -s -m 755 $(SLIB) "$(prefix)"
else
install -d $(prefix)/lib
@@ -71,4 +82,3 @@
ldconfig || true
endif
else
-
diff --git a/packages/ffmpeg/ffmpeg.inc b/packages/ffmpeg/ffmpeg.inc
new file mode 100644
index 0000000000..00f1423450
--- /dev/null
+++ b/packages/ffmpeg/ffmpeg.inc
@@ -0,0 +1,39 @@
+DESCRIPTION = "ffmpeg"
+HOMEPAGE = "http://ffmpeg.mplayerhq.hu/"
+AUTHOR = "Fabrice Bellard ffmpeg-devel@mplayerhq.hu"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+DEPENDS = "zlib libvorbis faac liba52 lame"
+RSUGGESTS = "mplayer"
+
+inherit autotools pkgconfig
+
+TARGET_LDFLAGS_append = " -lm -la52 "
+
+EXTRA_OECONF = "\
+ --enable-pp \
+ --enable-shared \
+ --enable-pthreads \
+ --enable-gpl \
+ \
+ --disable-audio-beos \
+ --disable-v4l \
+ --disable-dv1394 \
+ --disable-debug \
+ --disable-ffserver \
+ --disable-ffplay \
+ \
+ --cross-prefix=${TARGET_PREFIX} \
+ \
+ --cpu=${PACKAGE_ARCH} \
+ \
+"
+
+# We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
+PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
+
+do_configure_prepend() {
+ export CC="${CC}"
+}
diff --git a/packages/ffmpeg/ffmpeg/.mtn2git_empty b/packages/ffmpeg/ffmpeg/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ffmpeg/ffmpeg/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ffmpeg/ffmpeg/common.patch b/packages/ffmpeg/ffmpeg/common.patch
deleted file mode 100644
index 233a454a48..0000000000
--- a/packages/ffmpeg/ffmpeg/common.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ffmpeg/libavcodec/common.h.orig 2005-02-10 15:10:34.000000000 +0100
-+++ ffmpeg/libavcodec/common.h 2005-02-10 15:11:28.000000000 +0100
-@@ -501,10 +501,6 @@
- #define srand srand_is_forbidden_due_to_state_trashing
- #define sprintf sprintf_is_forbidden_due_to_security_issues_use_snprintf
- #define strcat strcat_is_forbidden_due_to_security_issues_use_pstrcat
--#if !(defined(LIBAVFORMAT_BUILD) || defined(_FRAMEHOOK_H))
--#define printf please_use_av_log
--#define fprintf please_use_av_log
--#endif
-
- #define CHECKED_ALLOCZ(p, size)\
- {\
diff --git a/packages/ffmpeg/ffmpeg/configure.patch b/packages/ffmpeg/ffmpeg/configure.patch
deleted file mode 100644
index ae13b861b0..0000000000
--- a/packages/ffmpeg/ffmpeg/configure.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- ./configure~configure.patch 2004-07-06 03:36:16.000000000 +0930
-+++ ./configure 2004-09-27 00:07:23.000000000 +0930
-@@ -88,7 +88,7 @@
- mandir=""
- bindir=""
- cross_prefix=""
--cc="gcc"
-+cc="$CC"
- ar="ar"
- ranlib="ranlib"
- make="make"
-@@ -104,7 +104,7 @@
- cpu="x86"
- ;;
- # armv4l is a subset of armv5tel
-- armv4l|armv5tel)
-+ armv4l|armv5tel|arm|xscale)
- cpu="armv4l"
- ;;
- alpha)
-@@ -434,6 +434,37 @@
- esac
- done
-
-+case "$cpu" in
-+ i386|i486|i586|i686|i86pc|BePC)
-+ cpu="x86"
-+ ;;
-+ # armv4l is a subset of armv5tel
-+ armv4l|armv5tel|arm|xscale)
-+ cpu="armv4l"
-+ ;;
-+ alpha)
-+ cpu="alpha"
-+ ;;
-+ "Power Macintosh"|ppc)
-+ cpu="powerpc"
-+ ;;
-+ mips)
-+ cpu="mips"
-+ ;;
-+ sun4u|sparc64)
-+ cpu="sparc64"
-+ ;;
-+ sparc)
-+ cpu="sparc"
-+ ;;
-+ sh4)
-+ cpu="sh4"
-+ ;;
-+ *)
-+ cpu="unknown"
-+ ;;
-+esac
-+
- if test "$gpl" != "yes"; then
- if test "$pp" != "no" -o "$shared_pp" != "no"; then
- echo "The Postprocessing code is under GPL and --enable-gpl is not specified"
-@@ -662,7 +693,6 @@
- bindir="$prefix"
- fi
-
--cc="${cross_prefix}${cc}"
- ar="${cross_prefix}${ar}"
- ranlib="${cross_prefix}${ranlib}"
- strip="${cross_prefix}${strip}"
-@@ -753,21 +783,6 @@
- fi
-
- if test "$zlib" = "yes"; then
--# check for zlib - mmu_man
--cat > $TMPC << EOF
--#include <zlib.h>
--int main ( void ) {
--if (zlibVersion() != ZLIB_VERSION)
-- puts("zlib version differs !!!");
-- return 1;
--return 0;
--}
--EOF
--$cc $CFLAGS -o $TMPE $TMPC -lz 2> /dev/null || zlib="no"
--# $TMPE 2> /dev/null > /dev/null || zlib="no"
--# XXX: more tests needed - runtime test
--fi
--if test "$zlib" = "yes"; then
- extralibs="$extralibs -lz"
- fi
diff --git a/packages/ffmpeg/ffmpeg/soname.patch b/packages/ffmpeg/ffmpeg/soname.patch
deleted file mode 100644
index 6d01f922af..0000000000
--- a/packages/ffmpeg/ffmpeg/soname.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- ffmpeg/libavcodec/Makefile.orig 2005-02-10 18:11:57.000000000 +0100
-+++ ffmpeg/libavcodec/Makefile 2005-02-10 18:15:36.000000000 +0100
-@@ -7,7 +7,7 @@
- VPATH=$(SRC_PATH)/libavcodec
-
- # NOTE: -I.. is needed to include config.h
--CFLAGS=$(OPTFLAGS) -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
-+CFLAGS=$(OPTFLAGS) -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -fPIC -DPIC
-
- OBJS= bitstream.o utils.o mem.o allcodecs.o \
- mpegvideo.o jrevdct.o jfdctfst.o jfdctint.o\
-@@ -222,7 +222,7 @@
- $(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS)
- -lib /machine:i386 /def:$(@:.dll=.def)
- else
-- $(CC) $(SHFLAGS) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS) $(LDFLAGS)
-+ $(CC) $(SHFLAGS) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS) $(LDFLAGS) -Wl,-soname -Wl,libavcodec.so.0
- endif
-
- dsputil.o: dsputil.c dsputil.h
-@@ -294,8 +294,9 @@
- install $(INSTALLSTRIP) -m 755 $(SLIB) "$(prefix)"
- else
- install -d $(prefix)/lib
-- install $(INSTALLSTRIP) -m 755 $(SLIB) $(prefix)/lib/libavcodec-$(VERSION).so
-- ln -sf libavcodec-$(VERSION).so $(prefix)/lib/libavcodec.so
-+ install -m 755 $(SLIB) $(prefix)/lib/libavcodec.so.0.4.9
-+ ln -sf libavcodec.so.0.4.9 $(prefix)/lib/libavcodec.so.0
-+ ln -sf libavcodec.so.0.4.9 $(prefix)/lib/libavcodec.so
- ldconfig || true
- endif
- ifeq ($(CONFIG_PP),yes)
-
---- ffmpeg/libavformat/Makefile.orig 2005-02-10 18:15:50.000000000 +0100
-+++ ffmpeg/libavformat/Makefile 2005-02-10 18:18:23.000000000 +0100
-@@ -6,7 +6,7 @@
-
- VPATH=$(SRC_PATH)/libavformat
-
--CFLAGS=$(OPTFLAGS) -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
-+CFLAGS=$(OPTFLAGS) -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -fPIC -DPIC
-
- OBJS= utils.o cutils.o os_support.o allformats.o
- PPOBJS=
-@@ -104,7 +104,7 @@
- $(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) $(VPATH)/../libavcodec/avcodec.dll
- -lib /machine:i386 /def:$(@:.dll=.def)
- else
-- $(CC) $(SHFLAGS) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS)
-+ $(CC) $(SHFLAGS) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) -Wl,-soname -Wl,libavformat.so.0
- endif
-
- depend: $(SRCS)
-@@ -116,8 +116,9 @@
- install $(INSTALLSTRIP) -m 755 $(SLIB) "$(prefix)"
- else
- install -d $(prefix)/lib
-- install $(INSTALLSTRIP) -m 755 $(SLIB) $(prefix)/lib/libavformat-$(VERSION).so
-- ln -sf libavformat-$(VERSION).so $(prefix)/lib/libavformat.so
-+ install -m 755 $(SLIB) $(prefix)/lib/libavformat.so.0.4.9
-+ ln -sf libavformat.so.0.4.9 $(prefix)/lib/libavformat.so.0
-+ ln -sf libavformat.so.0.4.9 $(prefix)/lib/libavformat.so
- ldconfig || true
- endif
- else
diff --git a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
index 12a73cceb6..defc37daa0 100644
--- a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
+++ b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
@@ -1,85 +1,60 @@
+require ffmpeg.inc
-DESCRIPTION = "ffmpeg"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "zlib libvorbis faad2 faac liba52 lame mplayer"
-LICENSE = "LGPL"
-PR = "r1"
+DEPENDS += "faad2"
-
-inherit autotools
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/ffmpeg/ffmpeg-${PV}.tar.gz \
file://configure.patch;patch=0 \
- file://common.patch;patch=1 \
+ file://gcc4.patch;patch=1 \
file://soname.patch;patch=1 \
"
-TARGET_LDFLAGS_append = " -lm -la52 "
-
-EXTRA_OECONF=" \
- --enable-mp3lame \
- --enable-vorbis \
- --enable-faad \
- --enable-faadbin \
- --enable-faac \
- --enable-a52 \
- --enable-a52bin \
- --enable-pp \
- --enable-shared-pp \
- --enable-shared \
- --disable-amr_nb \
- --enable-amr_nb-fixed \
- --disable-amr_wb \
- --enable-pthreads \
- --enable-gpl \
- --enable-zlib \
- \
- --disable-audio-beos \
- --disable-v4l \
- --disable-dv1394 \
- --disable-debug \
- --disable-ffserver \
- --disable-ffplay \
- \
- --cross-prefix=${TARGET_PREFIX} \
- --extra-cflags=\$(TARGET_CFLAGS) \
- --extra-ldflags=\$(TARGET_LDFLAGS) \
- --extra-libs=\$(TARGET_LDFLAGS) \
- \
- --cpu=${PACKAGE_ARCH} \
- --prefix=${D}${prefix} \
- --mandir=${D}${prefix}/share/man \
+EXTRA_OECONF += " \
+ --enable-mp3lame \
+ --enable-vorbis \
+ --enable-faad \
+ --enable-faadbin \
+ --enable-faac \
+ --enable-a52 \
+ --enable-a52bin \
+ --enable-shared-pp \
+ --disable-amr_nb \
+ --enable-amr_nb-fixed \
+ --disable-amr_wb \
+ --enable-zlib \
+ \
+ \
+ --extra-cflags=\$(TARGET_CFLAGS) \
+ --extra-ldflags=\$(TARGET_LDFLAGS) \
+ --extra-libs=\$(TARGET_LDFLAGS) \
+ \
+ --prefix=${D}${prefix} \
+ --mandir=${D}${prefix}/share/man \
"
PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
-FILES_${PN} = "${bindir}"
+
+FILES_${PN} += "${libdir}/vhook"
FILES_${PN}-dev = "${includedir}"
+FILES_${PN}-dbg += "${libdir}/vhook/.debug"
+
FILES_libavcodec = "${libdir}/libavcodec*.so.*"
FILES_libavcodec-dev = "${libdir}/libavcodec*.so ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
FILES_libavformat = "${libdir}/libavformat*.so.*"
FILES_libavformat-dev = "${libdir}/libavformat*.so ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
-# We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
-
-# --enable-shared-pp \
-
-do_configure_prepend() {
- export CC="${CC}"
-}
-
do_stage() {
- oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
- oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ffmpeg
- install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
- install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
- install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
- install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
- install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
- install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
- install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
- install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
+ oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/ffmpeg
+ install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
+ install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
+ install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
+ install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
+ install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
+ install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
+ install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
+ install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
}
diff --git a/packages/ffmpeg/ffmpeg_svn.bb b/packages/ffmpeg/ffmpeg_svn.bb
index 5276a8fef6..5742d26f5a 100644
--- a/packages/ffmpeg/ffmpeg_svn.bb
+++ b/packages/ffmpeg/ffmpeg_svn.bb
@@ -1,10 +1,9 @@
-DESCRIPTION = "ffmpeg"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL"
-DEPENDS = "libogg zlib libvorbis faac liba52 lame"
+require ffmpeg.inc
+
+DEPENDS += "libogg"
+
PV = "0.4.9+svnr${SRCREV}"
-PR = "r1"
+PR = "r2"
DEFAULT_PREFERENCE = "-1"
@@ -12,45 +11,22 @@ SRC_URI = "svn://svn.mplayerhq.hu/ffmpeg/;module=trunk"
S = "${WORKDIR}/trunk"
-inherit autotools pkgconfig
-
-TARGET_LDFLAGS_append = " -lm -la52 "
-
-EXTRA_OECONF = " \
- --enable-libmp3lame \
+EXTRA_OECONF += " \
+ --enable-libmp3lame \
--enable-libvorbis \
--disable-libfaad \
--enable-liba52 \
--enable-liba52bin \
--enable-libogg \
- --enable-pp \
- --enable-shared \
- --enable-pthreads \
--enable-gpl \
\
- --disable-audio-beos \
- --disable-v4l \
- --disable-dv1394 \
- --disable-debug \
- --disable-ffserver \
- --disable-ffplay \
- --disable-strip \
+ --disable-strip \
\
- --cross-prefix=${TARGET_PREFIX} \
\
--cpu=${PACKAGE_ARCH} \
- --arch=${PACKAGE_ARCH} \
+ --arch=${PACKAGE_ARCH} \
"
-
-# We do this because the install program is called with -s
-# which causes it to call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
-
-do_configure_prepend() {
- export CC="${CC}"
-}
-
oe_runconf () {
# make ffmpeg detect arm targets that don't end in 'l'
sed -i -e s:'armv\[4567\]\*l':'armv\[4567\]\*':g ${S}/configure
@@ -70,6 +46,7 @@ oe_runconf () {
do_stage() {
oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavdevice libavdevice ${STAGING_LIBDIR}
oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
oe_libinstall -a -so -C libavutil libavutil ${STAGING_LIBDIR}
oe_libinstall -a -so -C libpostproc libpostproc ${STAGING_LIBDIR}
@@ -77,7 +54,8 @@ do_stage() {
install -d ${STAGING_INCDIR}/ffmpeg
install -m 0644 ${S}/libavcodec/avcodec.h \
${STAGING_INCDIR}/ffmpeg/avcodec.h
-
+ install -m 0644 ${S}/libavdevice/avdevice.h \
+ ${STAGING_INCDIR}/ffmpeg/avdevice.h
install -m 0644 ${S}/libavformat/avformat.h \
${STAGING_INCDIR}/ffmpeg/avformat.h
install -m 0644 ${S}/libavformat/avio.h \
@@ -116,26 +94,36 @@ do_stage() {
}
PACKAGES += "libavcodec libavcodec-dev \
+ libavdevice libavdevice-dev \
libavformat libavformat-dev \
libavutil libavutil-dev \
libpostproc libpostproc-dev"
-FILES_${PN} = "${bindir}"
-FILES_${PN}-dev = "${includedir}"
+FILES_${PN} = "${bindir} ${libdir}/vhook"
+FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig/libswscale.pc"
FILES_${PN}-doc = "${mandir}"
FILES_libavcodec = "${libdir}/libavcodec*.so.*"
FILES_libavcodec-dev = "${libdir}/libavcodec*.so \
+ ${libdir}/pkgconfig/libavcodec.pc \
${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
+FILES_libavdevice = "${libdir}/libavdevice*.so.*"
+FILES_libavdevice-dev = "${libdir}/libavdevice*.so \
+ ${libdir}/pkgconfig/libavdevice.pc \
+ ${libdir}/libavdevice*.la ${libdir}/libavdevice*.a"
+
FILES_libavformat = "${libdir}/libavformat*.so.*"
FILES_libavformat-dev = "${libdir}/libavformat*.so \
+ ${libdir}/pkgconfig/libavformat.pc \
${libdir}/libavformat*.la ${libdir}/libavformat*.a"
FILES_libavutil = "${libdir}/libavutil*.so.*"
FILES_libavutil-dev = "${libdir}/libavutil*.so \
+ ${libdir}/pkgconfig/libavutil.pc \
${libdir}/libavutil*.la ${libdir}/libavutil*.a"
FILES_libpostproc = "${libdir}/libpostproc*.so.*"
FILES_libpostproc-dev = "${libdir}/libpostproc*.so \
+ ${libdir}/pkgconfig/libpostproc.pc \
${libdir}/libpostproc*.la ${libdir}/libpostproc*.a"