aboutsummaryrefslogtreecommitdiffstats
path: root/packages/file
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-03-02 15:12:23 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-03-02 15:12:23 +0000
commit3df911cf4b9fa4d871ef96e7d9f61a50c6890fbe (patch)
treeb6f8131970f64898588bd7f372f8d3a0b74ea920 /packages/file
parentd7e1c4cc66e8f03cae9901290f6982bf4486b29f (diff)
downloadopenembedded-3df911cf4b9fa4d871ef96e7d9f61a50c6890fbe.tar.gz
file-native_4.20.bb,file_4.20.bb : new version of everyones favourite util.
Diffstat (limited to 'packages/file')
-rw-r--r--packages/file/file-native_4.20.bb8
-rw-r--r--packages/file/file_4.20.bb18
2 files changed, 26 insertions, 0 deletions
diff --git a/packages/file/file-native_4.20.bb b/packages/file/file-native_4.20.bb
new file mode 100644
index 0000000000..b797cff8ad
--- /dev/null
+++ b/packages/file/file-native_4.20.bb
@@ -0,0 +1,8 @@
+require file_${PV}.bb
+inherit native
+
+# avoid dependency loop
+DEPENDS = ""
+PR = "r0"
+
+SRC_URI += "file://native-fix.diff;patch=1"
diff --git a/packages/file/file_4.20.bb b/packages/file/file_4.20.bb
new file mode 100644
index 0000000000..2b37d2515c
--- /dev/null
+++ b/packages/file/file_4.20.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+SECTION = "console/utils"
+LICENSE = "BSD-ADV"
+DEPENDS = "file-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz"
+S = "${WORKDIR}/file-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}