aboutsummaryrefslogtreecommitdiffstats
path: root/packages/flac
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-01-05 20:15:31 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-05 20:15:31 +0000
commit3bb17b52f032e6e48cefe2aa4d3d5bd241bb2193 (patch)
treed2a997c900155380382709eb2565779b042997fa /packages/flac
parent37e9384db9d918b12f9f757e3aa74ba883d7684e (diff)
downloadopenembedded-3bb17b52f032e6e48cefe2aa4d3d5bd241bb2193.tar.gz
flac: revert deletion of do_stage() applied in 1afdc843b65bacc2cfc4f7a91dea88affeaf5bd5
Diffstat (limited to 'packages/flac')
-rw-r--r--packages/flac/flac_1.1.0.bb45
1 files changed, 43 insertions, 2 deletions
diff --git a/packages/flac/flac_1.1.0.bb b/packages/flac/flac_1.1.0.bb
index 0396208ce4..f1cf8a6fb8 100644
--- a/packages/flac/flac_1.1.0.bb
+++ b/packages/flac/flac_1.1.0.bb
@@ -3,7 +3,7 @@ MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
LICENSE = "BSD GPL"
SECTION = "libs"
DEPENDS = "libogg"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
file://disable-xmms-plugin.patch;patch=1 \
@@ -34,5 +34,46 @@ do_configure () {
}
do_stage () {
- autotools_stage_all
+ install -d ${STAGING_DATADIR}/aclocal
+
+ oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/OggFLAC
+ install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h
+ install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h
+ install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h
+ install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h
+ install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/
+
+ oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/FLAC
+ install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h
+ install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h
+ install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h
+ install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h
+ install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h
+ install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h
+ install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h
+ install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h
+ install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h
+ install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h
+ install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h
+ install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h
+ install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/
+
+ oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/FLAC++
+ install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h
+ install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h
+ install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h
+ install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h
+ install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h
+ install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/
+
+ oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/OggFLAC++
+ install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h
+ install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h
+ install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h
+ install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h
+ install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/
}