aboutsummaryrefslogtreecommitdiffstats
path: root/packages/flac
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-12-29 16:32:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-29 16:32:55 +0000
commite08b2e93f70923ca872325127d0f294747f71d5c (patch)
tree6bd28988354ccfdab2dda9e8817d0e5530a22377 /packages/flac
parent291f9a7168c3331eb00cde9735bc6feeb7418f67 (diff)
downloadopenembedded-e08b2e93f70923ca872325127d0f294747f71d5c.tar.gz
flac: change do_stage to use autotools_do_stage in 1.1.0
Diffstat (limited to 'packages/flac')
-rw-r--r--packages/flac/flac_1.1.0.bb45
1 files changed, 2 insertions, 43 deletions
diff --git a/packages/flac/flac_1.1.0.bb b/packages/flac/flac_1.1.0.bb
index 4eb24a1849..0396208ce4 100644
--- a/packages/flac/flac_1.1.0.bb
+++ b/packages/flac/flac_1.1.0.bb
@@ -3,7 +3,7 @@ MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
LICENSE = "BSD GPL"
SECTION = "libs"
DEPENDS = "libogg"
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
file://disable-xmms-plugin.patch;patch=1 \
@@ -34,46 +34,5 @@ do_configure () {
}
do_stage () {
- install -d ${STAGING_DATADIR}/aclocal
-
- oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/OggFLAC
- install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h
- install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h
- install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h
- install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h
- install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/
-
- oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/FLAC
- install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h
- install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h
- install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h
- install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h
- install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h
- install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h
- install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h
- install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h
- install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h
- install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h
- install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h
- install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h
- install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/
-
- oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/FLAC++
- install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h
- install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h
- install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h
- install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h
- install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h
- install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/
-
- oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/
- install -d ${STAGING_INCDIR}/OggFLAC++
- install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h
- install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h
- install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h
- install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h
- install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/
+ autotools_stage_all
}