aboutsummaryrefslogtreecommitdiffstats
path: root/packages/flnx
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/flnx
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/flnx')
-rw-r--r--packages/flnx/flnx_0.17.bb6
-rw-r--r--packages/flnx/flnx_0.18.bb32
2 files changed, 35 insertions, 3 deletions
diff --git a/packages/flnx/flnx_0.17.bb b/packages/flnx/flnx_0.17.bb
index b453ad24b1..e2db1358d8 100644
--- a/packages/flnx/flnx_0.17.bb
+++ b/packages/flnx/flnx_0.17.bb
@@ -10,7 +10,7 @@ inherit autotools
EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
do_install () {
- oe_runmake "bindir=${D}/${bindir}" \
- "libdir=${D}/${libdir}" \
- "includedir=${D}/${includedir}" install
+ oe_runmake "bindir=${D}${bindir}" \
+ "libdir=${D}${libdir}" \
+ "includedir=${D}${includedir}" install
}
diff --git a/packages/flnx/flnx_0.18.bb b/packages/flnx/flnx_0.18.bb
index e69de29bb2..6f84247404 100644
--- a/packages/flnx/flnx_0.18.bb
+++ b/packages/flnx/flnx_0.18.bb
@@ -0,0 +1,32 @@
+SECTION = "x11/libs"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+DESCRIPTION = "fltk library for microwindows."
+SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}-tar.gz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/flnx"
+LICENSE = "LGPL"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
+
+python do_fetch () {
+ import os
+ bb.build.exec_func("base_do_fetch", d)
+ if os.access(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), os.R_OK):
+ os.rename(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), bb.data.expand("${DL_DIR}/flnx-${PV}.tar.gz", d))
+}
+
+python do_unpack () {
+ src_uri = bb.data.getVar("SRC_URI", d)
+ src_uri = src_uri.replace("-tar", ".tar")
+ bb.data.setVar("SRC_URI", src_uri, d)
+ bb.build.exec_func("base_do_unpack", d)
+}
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "libdir=${D}${libdir}" \
+ "includedir=${D}${includedir}" install
+}