aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fmtools
diff options
context:
space:
mode:
authorSergey Bostandzhyan <jin@mediatomb.org>2007-12-23 20:54:04 +0000
committerMatthias Hentges <oe@hentges.net>2007-12-23 20:54:04 +0000
commit42f8d9c2bfe293aa9aa2b849ed06b5161473e8da (patch)
treecd5327aaf0c2864779988735d903b46c422aa905 /packages/fmtools
parent4169220a9f970264b6b1ff75bfd065c380827a83 (diff)
downloadopenembedded-42f8d9c2bfe293aa9aa2b849ed06b5161473e8da.tar.gz
fmtools: Add fmtools package, courtesy of Jin^eLD
Diffstat (limited to 'packages/fmtools')
-rw-r--r--packages/fmtools/.mtn2git_empty0
-rw-r--r--packages/fmtools/files/.mtn2git_empty0
-rw-r--r--packages/fmtools/files/makefile.patch11
-rw-r--r--packages/fmtools/fmtools_1.0.2.bb15
4 files changed, 26 insertions, 0 deletions
diff --git a/packages/fmtools/.mtn2git_empty b/packages/fmtools/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fmtools/.mtn2git_empty
diff --git a/packages/fmtools/files/.mtn2git_empty b/packages/fmtools/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fmtools/files/.mtn2git_empty
diff --git a/packages/fmtools/files/makefile.patch b/packages/fmtools/files/makefile.patch
new file mode 100644
index 0000000000..41c0086b82
--- /dev/null
+++ b/packages/fmtools/files/makefile.patch
@@ -0,0 +1,11 @@
+--- fmtools-1.0.2/Makefile 2002-08-17 06:05:09.000000000 +0200
++++ fmtools-1.0.2p/Makefile 2007-12-22 21:45:28.000000000 +0100
+@@ -1,8 +1,5 @@
+ # fmtools Makefile - just the basics for now
+
+-CC = gcc
+-CFLAGS = -Wall -O2
+-
+ INSTALL = /usr/bin/install
+
+ # Since fmtools doesn't use configure, these paths are provided here
diff --git a/packages/fmtools/fmtools_1.0.2.bb b/packages/fmtools/fmtools_1.0.2.bb
new file mode 100644
index 0000000000..a1f9fb0f39
--- /dev/null
+++ b/packages/fmtools/fmtools_1.0.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "fmtools - programs for Video for Linux radio cards"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.stanford.edu/~blp/fmtools/fmtools-1.0.2.tar.gz \
+ file://makefile.patch;patch=1"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/fm ${D}${bindir}/fm
+ install -m 0755 ${S}/fmscan ${D}${bindir}/fmscan
+}
+