aboutsummaryrefslogtreecommitdiffstats
path: root/packages/freenote
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-01-07 18:25:55 +0000
committerHolger Freyther <zecke@selfish.org>2008-01-07 18:25:55 +0000
commit484aec6e78dd9624f20779130565d1774d5b9e9f (patch)
tree669af5386d34b447d37985fb5ab095bf851c3a68 /packages/freenote
parentd1631785248a72bb4d02cd55307b2a994fa5673a (diff)
downloadopenembedded-484aec6e78dd9624f20779130565d1774d5b9e9f.tar.gz
Bashism fix: echo -e is a bashism and doesn't work when /bin/sh points to dash
Instead of using "echo -e" we simply use printf. printf doesn't add a newline by default. So some places needed an extra \n in their string. Most of the change was done by hand, so please carefully review. This bug was spotted when trying to compile python-pyqt on my ubuntu hardy system.
Diffstat (limited to 'packages/freenote')
-rw-r--r--packages/freenote/freenote_1.12.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/freenote/freenote_1.12.0.bb b/packages/freenote/freenote_1.12.0.bb
index 72610c306c..e28689ebf0 100644
--- a/packages/freenote/freenote_1.12.0.bb
+++ b/packages/freenote/freenote_1.12.0.bb
@@ -15,7 +15,7 @@ inherit opie
do_configure_prepend() {
mv -f FreeNote subdir1
mv -f FreeNoteSetup subdir2
- echo -e "TEMPLATE=subdirs\nSUBDIRS=subdir1 subdir2\n" >> freenote.pro
+ printf "TEMPLATE=subdirs\nSUBDIRS=subdir1 subdir2\n" >> freenote.pro
pushd ${S}/subdir1 && rm *.pro && qmake -project && echo "TARGET=FreeNote" >> subdir1.pro && popd
pushd ${S}/subdir2 && rm *.pro && qmake -project && echo "TARGET=FreeNoteSetup" >> subdir2.pro && popd
}