aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fxload
diff options
context:
space:
mode:
authorTim Sander <oe@iss.tu-darmstadt.de>2007-09-09 20:30:44 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-09-09 20:30:44 +0000
commit2ca3d466f4edebf91a8629448c8b92dfa4442edd (patch)
tree483414e102ec46b5ad9159f3428046031a807ffe /packages/fxload
parent1e4f897d09da199be03b3a34fad08c82ec826ada (diff)
downloadopenembedded-2ca3d466f4edebf91a8629448c8b92dfa4442edd.tar.gz
fxload: a firmware uploader for ezusb chips
Diffstat (limited to 'packages/fxload')
-rw-r--r--packages/fxload/.mtn2git_empty0
-rw-r--r--packages/fxload/files/.mtn2git_empty0
-rw-r--r--packages/fxload/files/usbheader.patch15
-rw-r--r--packages/fxload/fxload_0.0.20020411.bb19
4 files changed, 34 insertions, 0 deletions
diff --git a/packages/fxload/.mtn2git_empty b/packages/fxload/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fxload/.mtn2git_empty
diff --git a/packages/fxload/files/.mtn2git_empty b/packages/fxload/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/fxload/files/.mtn2git_empty
diff --git a/packages/fxload/files/usbheader.patch b/packages/fxload/files/usbheader.patch
new file mode 100644
index 0000000000..db205e9ab5
--- /dev/null
+++ b/packages/fxload/files/usbheader.patch
@@ -0,0 +1,15 @@
+--- fxload-0.0.20020411.orig/ezusb.c
++++ fxload-0.0.20020411/ezusb.c
+@@ -29,7 +29,11 @@
+ # include <sys/ioctl.h>
+
+ # include <linux/version.h>
+-# include <linux/usb.h>
++#if (LINUX_VERSION_CODE >= 132630)
++# include <linux/usb/ch9.h>
++#else
++# include <linux/usb_ch9.h>
++#endif
+ # include <linux/usbdevice_fs.h>
+
+ # include "ezusb.h"
diff --git a/packages/fxload/fxload_0.0.20020411.bb b/packages/fxload/fxload_0.0.20020411.bb
new file mode 100644
index 0000000000..2bebded964
--- /dev/null
+++ b/packages/fxload/fxload_0.0.20020411.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "fxload loads firmware into the ezusb chips"
+AUTHOR = "Stephen Williams, David Brownell"
+HOMEPAGE = "http://linux-hotplug.sourceforge.net/"
+SECTION = "admin"
+LICENSE = "GPL"
+DEPENDS = "linux-libc-headers"
+PR = "r1"
+
+SRC_URI = "http://dfn.dl.sourceforge.net/sourceforge/linux-hotplug/fxload-2002_04_11.tar.gz \
+ file://usbheader.patch;patch=1"
+
+S = "${WORKDIR}/fxload-2002_04_11"
+
+FILES_${PN} = "${base_sbindir}/fxload"
+
+do_install() {
+ mkdir -p ${D}/sbin/
+ cp ${S}/fxload ${D}/sbin/fxload
+}