aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc-snapshot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gcc-snapshot
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gcc-snapshot')
-rw-r--r--packages/gcc-snapshot/.mtn2git_empty0
-rw-r--r--packages/gcc-snapshot/gcc-snapshot-cross-initial_cvs.bb28
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/gcc-snapshot/.mtn2git_empty b/packages/gcc-snapshot/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gcc-snapshot/.mtn2git_empty
diff --git a/packages/gcc-snapshot/gcc-snapshot-cross-initial_cvs.bb b/packages/gcc-snapshot/gcc-snapshot-cross-initial_cvs.bb
index e69de29bb2..b4b324c533 100644
--- a/packages/gcc-snapshot/gcc-snapshot-cross-initial_cvs.bb
+++ b/packages/gcc-snapshot/gcc-snapshot-cross-initial_cvs.bb
@@ -0,0 +1,28 @@
+SECTION = "devel"
+include gcc-snapshot-cross_cvs.bb
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-initial"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
+
+PACKAGES = ""
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-multilib \
+ --disable-__cxa_atexit \
+ --enable-languages=c \
+ --enable-target-optspace \
+ --program-prefix=${TARGET_PREFIX}"
+
+do_stage_prepend () {
+ mkdir -p ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${PV}
+ ln -sf libgcc.a ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${PV}/libgcc_eh.a
+}
+
+# Override the method from gcc-cross so we don't try to install libgcc
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}