aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc/gcc-4.1.1
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-08-06 11:45:56 +0000
committerHolger Freyther <zecke@selfish.org>2006-08-06 11:45:56 +0000
commitb8d1ef0e4fb7c506a5c0de055a276159049df948 (patch)
treeda934a76e83ee9c8ddac03bbabc3d609567f3c94 /packages/gcc/gcc-4.1.1
parent44b1ddb504535400e1272d5d9259778249f36b47 (diff)
downloadopenembedded-b8d1ef0e4fb7c506a5c0de055a276159049df948.tar.gz
packages/gcc: For targets (libstdc++,java,mudflap...) use xgcc -E as CPP
GCC compiles the xgcc cross compiler and will compile target libraries e.g. libstdc++. It uses autoconf to configure the target libraries which uses /usr/bin/cpp to determine the presence of host includes. By using xgcc we will not risk to include /usr/include to find standard headers. If we do our cross compile check will hit. The gcc 3.4 series patch only addresses target-libstdc++ where the gcc3.3 and gcc4 series patch all targets
Diffstat (limited to 'packages/gcc/gcc-4.1.1')
-rw-r--r--packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..42ec190600
--- /dev/null
+++ b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.1.1/Makefile.in
+===================================================================
+--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200
++++ gcc-4.1.1/Makefile.in 2006-08-06 13:32:46.000000000 +0200
+@@ -194,6 +194,7 @@
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CCP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \