aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-15 13:39:18 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-15 13:39:18 +0000
commita58b26f88e2a4377e8c22f3a1269672815799c8c (patch)
tree43a04eb7471a46c3e74b8776acb4f715e8e789d4 /packages/gcc/gcc_4.1.2.bb
parent61f76f5ed16476df673e77ecea8113100426eb33 (diff)
downloadopenembedded-a58b26f88e2a4377e8c22f3a1269672815799c8c.tar.gz
gcc: Create .inc files for each gcc version and update all .bb files to use these
Diffstat (limited to 'packages/gcc/gcc_4.1.2.bb')
-rw-r--r--packages/gcc/gcc_4.1.2.bb77
1 files changed, 1 insertions, 76 deletions
diff --git a/packages/gcc/gcc_4.1.2.bb b/packages/gcc/gcc_4.1.2.bb
index fc75e942bb..4bdf9a2459 100644
--- a/packages/gcc/gcc_4.1.2.bb
+++ b/packages/gcc/gcc_4.1.2.bb
@@ -1,76 +1 @@
-DESCRIPTION = "The GNU cc and gcc C compilers."
-HOMEPAGE = "http://www.gnu.org/software/gcc/"
-SECTION = "devel"
-LICENSE = "GPL"
-# NOTE: split PR. If the main .bb changes something that affects its *build*
-# remember to increment the -cross .bb PR too.
-PR = "r11"
-
-inherit autotools gettext
-
-require gcc-package.inc
-
-SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://cache-amnesia.patch;patch=1 \
- file://gfortran.patch;patch=1 \
- file://gcc-4.0.2-e300c2c3.patch;patch=1 \
- file://pr34130.patch;patch=1 \
- "
-
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
-
-SRC_URI_avr32 = "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
-# file://100-uclibc-conf.patch;patch=1 \
-# file://200-uclibc-locale.patch;patch=1 \
-# file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://cache-amnesia.patch;patch=1 \
- "
-
-do_compile_prepend_avr32() {
- ln -sf ${S}/libstdc++-v3/config/os/uclibc/ ${S}/libstdc++-v3/config/os/uclibc-linux
-}
-
-#Set the fortran bits
-# ',fortran' or '', not 'f77' like gcc3 had
-FORTRAN = ""
-
-#Set the java bits
-JAVA = ""
-JAVA_arm = ""
-
-
-LANGUAGES = "c,c++${FORTRAN}${JAVA}"
-require gcc3-build.inc
-ARCH_FLAGS_FOR_TARGET=-isystem${STAGING_INCDIR}
-
-
-EXTRA_OECONF += " --disable-libssp "
-
+require gcc-${PV}.inc