aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-31 07:45:26 +0000
committerKoen Kooi <koen@openembedded.org>2006-07-31 07:45:26 +0000
commit4dc4913394970994f56114128d4fac97665a8840 (patch)
treef9c442fec1309b4da5982a99d7af6251c93f268a /packages/gcc
parent7bfab4149a434f3005d642cc50d4d180c1218e35 (diff)
downloadopenembedded-4dc4913394970994f56114128d4fac97665a8840.tar.gz
gcc: make fortran switches behave like the java switches to battle the 'g++ disappeared' symptoms
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc3-build.inc4
-rw-r--r--packages/gcc/gcc4-build.inc2
-rw-r--r--packages/gcc/gcc_4.1.1.bb1
3 files changed, 4 insertions, 3 deletions
diff --git a/packages/gcc/gcc3-build.inc b/packages/gcc/gcc3-build.inc
index d15664549e..6260a51533 100644
--- a/packages/gcc/gcc3-build.inc
+++ b/packages/gcc/gcc3-build.inc
@@ -17,8 +17,8 @@ JAVA_armeb ?= ""
JAVA_mipsel ?= ""
JAVA_sh3 ?= ""
# gcc4-build sets this to f95
-FORTRAN ?= "f77"
-LANGUAGES ?= "c,c++,${FORTRAN}${JAVA}"
+FORTRAN ?= ",f77"
+LANGUAGES ?= "c,c++${FORTRAN}${JAVA}"
EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']} \
--with-gnu-ld \
diff --git a/packages/gcc/gcc4-build.inc b/packages/gcc/gcc4-build.inc
index a2061194d7..b8a214a590 100644
--- a/packages/gcc/gcc4-build.inc
+++ b/packages/gcc/gcc4-build.inc
@@ -1,4 +1,4 @@
-FORTRAN = "f95"
+FORTRAN = ",f95"
HAS_GFORTRAN ?= "yes"
HAS_G2C = "no"
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index 35124823a0..c5af490b17 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -37,6 +37,7 @@ HAS_G2C = "no"
#Set the java bits
JAVA_arm = ""
+LANGUAGES = "c,c++"
include gcc3-build.inc