aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2008-12-07 13:44:40 -0500
committerTom Rini <trini@embeddedalley.com>2008-12-07 13:44:40 -0500
commit20e02f754192fbcf0d67e0efb28d04e26d8f6d94 (patch)
tree0621d0014b4c73aa2d18615b022f72495d2c69ea /packages/gcc
parent0b13ccb9a40b8184f5b5653ffad71af81593ef92 (diff)
downloadopenembedded-20e02f754192fbcf0d67e0efb28d04e26d8f6d94.tar.gz
gcc, gcc-native 3.4.6 : Oops, O_CREAT was already fixed
Undo my pushing of Jonas Bonn patch as I missed that it was fixed differently.
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-3.4.6.inc3
-rw-r--r--packages/gcc/gcc-3.4.6/O_CREAT-perms.patch11
2 files changed, 1 insertions, 13 deletions
diff --git a/packages/gcc/gcc-3.4.6.inc b/packages/gcc/gcc-3.4.6.inc
index a467860e9e..b1f686b365 100644
--- a/packages/gcc/gcc-3.4.6.inc
+++ b/packages/gcc/gcc-3.4.6.inc
@@ -17,8 +17,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
file://zecke-xgcc-cpp.patch;patch=1 \
file://gcc-posix.patch;patch=1 \
- file://gcc4-mtune-compat.patch;patch=1 \
- file://O_CREAT-perms.patch;patch=1"
+ file://gcc4-mtune-compat.patch;patch=1"
SRC_URI += "file://gcc34-configure.in.patch;patch=1"
SRC_URI += "file://gcc34-thumb-support.patch;patch=1"
diff --git a/packages/gcc/gcc-3.4.6/O_CREAT-perms.patch b/packages/gcc/gcc-3.4.6/O_CREAT-perms.patch
deleted file mode 100644
index 1c3af2e021..0000000000
--- a/packages/gcc/gcc-3.4.6/O_CREAT-perms.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc-3.4.6/gcc/collect2.c.orig 2008-10-20 14:47:56.000000000 +0200
-+++ gcc-3.4.6/gcc/collect2.c 2008-10-20 14:48:49.000000000 +0200
-@@ -1534,7 +1534,7 @@
- if (redir)
- {
- /* Open response file. */
-- redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT);
-+ redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT, 0644);
-
- /* Duplicate the stdout and stderr file handles
- so they can be restored later. */