aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gchub
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/gchub
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/gchub')
-rw-r--r--packages/gchub/gchub-module_svn.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/gchub/gchub-module_svn.bb b/packages/gchub/gchub-module_svn.bb
index e69de29bb2..37617e8030 100644
--- a/packages/gchub/gchub-module_svn.bb
+++ b/packages/gchub/gchub-module_svn.bb
@@ -0,0 +1,17 @@
+SECTION = "base"
+PRIORITY = "optional"
+DESCRIPTION = "Kernel module for the GameCube Hub input device"
+DEPENDS = "virtual/kernel"
+MAINTAINER = "Micah Dowty <micah@navi.cx>"
+LICENSE = "GPL"
+PV = "svn-${CVSDATE}"
+SRC_URI = "svn://navi.cx/svn/misc/trunk/wasabi/devices;module=gchub"
+
+S = "${WORKDIR}/gchub/kernel"
+
+inherit module
+
+do_install() {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb
+ install gchub.ko -m 0644 ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/gchub.ko
+}