aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gdb/gdb-cross_6.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gdb/gdb-cross_6.1.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gdb/gdb-cross_6.1.bb')
-rw-r--r--packages/gdb/gdb-cross_6.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/gdb/gdb-cross_6.1.bb b/packages/gdb/gdb-cross_6.1.bb
index e69de29bb2..c27960c7fd 100644
--- a/packages/gdb/gdb-cross_6.1.bb
+++ b/packages/gdb/gdb-cross_6.1.bb
@@ -0,0 +1,36 @@
+LICENSE = GPL
+DESCRIPTION = "gdb - GNU debugger"
+SECTION = "devel"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@nexus.co.uk>"
+DEPENDS = "ncurses-native"
+
+inherit autotools sdk
+
+S = "${WORKDIR}/gdb-${PV}"
+SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
+ file://sim-install.patch;patch=1"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
+
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CXX_FOR_BUILD = "${BUILD_CXX}"
+export CPP_FOR_BUILD = "${BUILD_CPP}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
+export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
+
+EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
+
+EXTRA_OECONF = "--with-curses --with-readline"
+
+do_configure () {
+# override this function to avoid the autoconf/automake/aclocal/autoheader
+# calls for now
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ :
+}