aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gdb/gdb_6.3.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-22 20:04:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-22 20:04:07 +0000
commit153ada05e0051228c641736634c255bc18962e81 (patch)
tree36dd05d65d17980d325dd16f30cd47b4689500e3 /packages/gdb/gdb_6.3.bb
parent3d947aa7a969ef9343e1d64b055d37d0ce856fb0 (diff)
downloadopenembedded-153ada05e0051228c641736634c255bc18962e81.tar.gz
gdb_6.3: patch the thumb handling to use a thumb swi (not an undefined instr)
This doesn't fix thumb debugging (a thumb program run under gdb will crash right at the start) but it does avoid the illegal instruction crash by inserting a swi instead.
Diffstat (limited to 'packages/gdb/gdb_6.3.bb')
-rw-r--r--packages/gdb/gdb_6.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/packages/gdb/gdb_6.3.bb b/packages/gdb/gdb_6.3.bb
index fcabfdc5f3..cbd7d3ff15 100644
--- a/packages/gdb/gdb_6.3.bb
+++ b/packages/gdb/gdb_6.3.bb
@@ -6,6 +6,7 @@ PRIORITY = "optional"
MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
DEPENDS = "ncurses readline"
RDEPENDS_openmn = "libthread-db1"
+PR = "r1"
PACKAGES =+ 'gdbserver '
FILES_gdbserver = '${bindir}/gdbserver'
@@ -16,6 +17,9 @@ SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
file://uclibc.patch;patch=1 \
file://gdbserver-cflags-last.diff;patch=1;pnum=0"
+# Patch the swi gdb is using for arm thumb code
+SRC_URI += "file://thumb-breakpoint.patch;patch=1"
+
LDFLAGS_append = " -s"
export CC_FOR_BUILD = "${BUILD_CC}"
export CXX_FOR_BUILD = "${BUILD_CXX}"