aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gettext
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-17 21:40:24 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-17 21:40:24 +0000
commit8bc61c54fdac2884d23ae3802afe7f5f81c7aff2 (patch)
tree131c8ed3980b6aa897fcb471314cfa01ae2193dd /packages/gettext
parent94d87cd53a89e085b09ca55c1bc05a7c313998e8 (diff)
downloadopenembedded-8bc61c54fdac2884d23ae3802afe7f5f81c7aff2.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/17 22:09:22+01:00 handhelds.org!zecke Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into handhelds.org:/home/ich/programming/oe/openembedded 2005/01/17 22:08:56+01:00 handhelds.org!zecke UICMOC use Qt2.3.9: -Use recent Qt2.3.9 for building uicmoc -Update patches to work with Qt2.3.9 version 2005/01/17 22:07:14+01:00 handhelds.org!zecke Qt 2.3.9: -Update to 14.01.2005 snapshot -TSlib patch is included but castrated, uncastrate it -The latest mouse release patch was fixed independently by Trolltech as well -Update other patches 2005/01/17 16:00:45-05:00 handhelds.org!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into handhelds.org:/home/kergoth/code/openembedded 2005/01/17 15:56:11-05:00 handhelds.org!kergoth Update the default event handler to clean things up a bit, and to mention the package version in the Pkg events, which people have requested in the past. 2005/01/17 20:49:43+00:00 rpsys.net!RP Add facility to pass parallel build option to make. Disable parallel build option for known broken packages. BKrev: 41ec30c8I5e1Ks5lsaghKSnrJo6cVg
Diffstat (limited to 'packages/gettext')
-rw-r--r--packages/gettext/gettext_0.14.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/gettext/gettext_0.14.1.bb b/packages/gettext/gettext_0.14.1.bb
index e69de29bb2..9e2222aa0e 100644
--- a/packages/gettext/gettext_0.14.1.bb
+++ b/packages/gettext/gettext_0.14.1.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The GNU internationalization library."
+HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r3"
+PROVIDES = "virtual/libintl"
+
+SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
+ file://gettext-vpath.patch;patch=1;pnum=1 \
+ file://fixchicken.patch;patch=1;pnum=1"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF += "--without-lisp"
+acpaths = '-I ${S}/autoconf-lib-link/m4/ \
+ -I ${S}/gettext-runtime/m4 \
+ -I ${S}/gettext-tools/m4'
+
+do_configure_prepend() {
+ rm -f ${S}/config/m4/libtool.m4
+ install -m 0644 ${STAGING_DATADIR}/aclocal/libtool.m4 ${S}/config/m4/
+}
+
+do_stage () {
+ autotools_stage_includes
+ oe_libinstall -so -C gettext-tools/lib libgettextlib ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-tools/src libgettextpo ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-tools/src libgettextsrc ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-tools/intl libintl ${STAGING_LIBDIR}/
+ oe_libinstall -so -C gettext-runtime/lib libasprintf ${STAGING_LIBDIR}/
+}