aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gettext
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-02-03 12:06:10 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-02-03 12:06:10 +0000
commita0bdc8cabdedfad025110767b9a071ad91ef537e (patch)
treec62bc89c016e6c2f070030efbd98589dfdc1e004 /packages/gettext
parent6dab0f35304a2fd02ad3a6f7e51b4e3a290c06ff (diff)
downloadopenembedded-a0bdc8cabdedfad025110767b9a071ad91ef537e.tar.gz
Fix getline error when compiling for uclibc
closes bug #1335
Diffstat (limited to 'packages/gettext')
-rw-r--r--packages/gettext/gettext-0.14.1/getline.m4.patch32
-rw-r--r--packages/gettext/gettext_0.14.1.bb5
2 files changed, 35 insertions, 2 deletions
diff --git a/packages/gettext/gettext-0.14.1/getline.m4.patch b/packages/gettext/gettext-0.14.1/getline.m4.patch
new file mode 100644
index 0000000000..c3f99bb9ae
--- /dev/null
+++ b/packages/gettext/gettext-0.14.1/getline.m4.patch
@@ -0,0 +1,32 @@
+--- /gettext-tools/m4/orig-getline.m4 2003-07-18 18:11:37.000000000 +0300
++++ /gettext-tools/m4/getline.m4 2007-02-03 13:33:41.000000000 +0200
+@@ -42,12 +42,23 @@
+ return 1;
+ len = getline (&line, &siz, in);
+ exit ((len == 4 && line && strcmp (line, "foo\n") == 0) ? 0 : 1);
+- }
+- ], am_cv_func_working_getline=yes dnl The library version works.
+- , am_cv_func_working_getline=no dnl The library version does NOT work.
+- , am_cv_func_working_getline=no dnl We're cross compiling.
+- )])
+- fi
++ }
++ ], am_cv_func_working_getline=yes dnl The library version works.
++ , am_cv_func_working_getline=no dnl The library version does NOT work.
++! , dnl We're cross compiling. Assume ir works on glibc2 systems.
++! [AC_EGREP_CPP([Lucky GNU user],
++! [
++! #include <features.h>
++! #ifdef __GNU_LIBRARY__
++! #if (__GLIBC__ >= 2)
++! Lucky GNU user
++! #endif
++! #endif
++! ],
++! [am_cv_func_working_getline=yes],
++! [am_cv_func_working_getline=no])]
++ )])
++ fi
+
+ if test $am_cv_func_working_getline = no; then
+ dnl We must choose a different name for our function, since on ELF systems
diff --git a/packages/gettext/gettext_0.14.1.bb b/packages/gettext/gettext_0.14.1.bb
index 9e2222aa0e..906aba8d53 100644
--- a/packages/gettext/gettext_0.14.1.bb
+++ b/packages/gettext/gettext_0.14.1.bb
@@ -2,12 +2,13 @@ DESCRIPTION = "The GNU internationalization library."
HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
SECTION = "libs"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
PROVIDES = "virtual/libintl"
SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
file://gettext-vpath.patch;patch=1;pnum=1 \
- file://fixchicken.patch;patch=1;pnum=1"
+ file://fixchicken.patch;patch=1;pnum=1 \
+ file://getline.m4.patch;patch=1"
PARALLEL_MAKE = ""