aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gimp
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-08-01 17:34:14 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-01 17:34:14 +0000
commit57c73bb9ef711a363673009ffd7bbc9e95f97b79 (patch)
treec3f849bc7bd4dadd8fee8ecd63fdd1e7a0f25f49 /packages/gimp
parentad4556c15df831cce48cf3dd1dfc7de3ca81b4dd (diff)
downloadopenembedded-57c73bb9ef711a363673009ffd7bbc9e95f97b79.tar.gz
Add gimp 2.3.2 with a nasty sed script in do_configure_append since I couldn't figure out how to patch to autofoo files to stop including -I/usr/include
Diffstat (limited to 'packages/gimp')
-rw-r--r--packages/gimp/gimp_2.3.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/gimp/gimp_2.3.2.bb b/packages/gimp/gimp_2.3.2.bb
new file mode 100644
index 0000000000..98237579d0
--- /dev/null
+++ b/packages/gimp/gimp_2.3.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE = "http://www.gimp.org"
+LICENSE = "GPL"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2"
+
+DEPENDS = "sed-native gtk+ jpeg libpng libexif tiff"
+
+inherit autotools pkgconfig
+#Don't laugh, this just builds a threaded gimp
+EXTRA_OECONF = " --disable-gtktest \
+ --disable-print \
+ --disable-python \
+ --enable-mp"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+}