aboutsummaryrefslogtreecommitdiffstats
path: root/packages/glib-2.0
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
committerHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
commit56b7d78a034187f66e08f3b3e2de55bd878cf9b5 (patch)
treed6f4033c0064f41c2205502d10c651e8710c96aa /packages/glib-2.0
parent9e61974759ef6e4ff9538a33bab0e82b1b4381dd (diff)
downloadopenembedded-56b7d78a034187f66e08f3b3e2de55bd878cf9b5.tar.gz
Micro-Optimisation decreasing initial parsing time by 10%
python () {} and python __anonymous () {} are as the same says functions without a name. They get executed when the main bb file is completely parsed. This is used to set information like FILESDIR. This is a python method so it gets evaled which means compiled and executed a lot of times. By moving the code of the anonfunc into a proper method this is only compiled once. The result is is the 10% speed up when parsing. Reindent anonfuncs and new defs without tabs and four spaces
Diffstat (limited to 'packages/glib-2.0')
-rw-r--r--packages/glib-2.0/glib-2.0.inc5
-rw-r--r--packages/glib-2.0/glib-2.0_2.12.0.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.12.1.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.12.3.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.2.3.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.4.5.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.4.6.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.6.0.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.6.1.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.6.2.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.6.3.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.6.4.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.8.1.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.8.2.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.8.4.bb5
-rw-r--r--packages/glib-2.0/glib-2.0_2.8.6.bb5
16 files changed, 20 insertions, 60 deletions
diff --git a/packages/glib-2.0/glib-2.0.inc b/packages/glib-2.0/glib-2.0.inc
new file mode 100644
index 0000000000..c8bde21cf2
--- /dev/null
+++ b/packages/glib-2.0/glib-2.0.inc
@@ -0,0 +1,5 @@
+
+python () {
+ if bb.data.getVar("USE_NLS", d, 1) == "no":
+ raise bb.parse.SkipPackage("${PN} requires native language support.")
+}
diff --git a/packages/glib-2.0/glib-2.0_2.12.0.bb b/packages/glib-2.0/glib-2.0_2.12.0.bb
index e60d465fd5..7d666b5903 100644
--- a/packages/glib-2.0/glib-2.0_2.12.0.bb
+++ b/packages/glib-2.0/glib-2.0_2.12.0.bb
@@ -24,10 +24,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.12.1.bb b/packages/glib-2.0/glib-2.0_2.12.1.bb
index 064f2f7f96..90904d0b54 100644
--- a/packages/glib-2.0/glib-2.0_2.12.1.bb
+++ b/packages/glib-2.0/glib-2.0_2.12.1.bb
@@ -24,10 +24,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.12.3.bb b/packages/glib-2.0/glib-2.0_2.12.3.bb
index 064f2f7f96..90904d0b54 100644
--- a/packages/glib-2.0/glib-2.0_2.12.3.bb
+++ b/packages/glib-2.0/glib-2.0_2.12.3.bb
@@ -24,10 +24,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.2.3.bb b/packages/glib-2.0/glib-2.0_2.2.3.bb
index 4288cb62eb..cf9722f2aa 100644
--- a/packages/glib-2.0/glib-2.0_2.2.3.bb
+++ b/packages/glib-2.0/glib-2.0_2.2.3.bb
@@ -19,10 +19,7 @@ PR = "r1"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.4.5.bb b/packages/glib-2.0/glib-2.0_2.4.5.bb
index c6f06e88b6..a1a6012398 100644
--- a/packages/glib-2.0/glib-2.0_2.4.5.bb
+++ b/packages/glib-2.0/glib-2.0_2.4.5.bb
@@ -30,10 +30,7 @@ PR = "r1"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.4.6.bb b/packages/glib-2.0/glib-2.0_2.4.6.bb
index d5b9b6f73f..5b47bc5d3c 100644
--- a/packages/glib-2.0/glib-2.0_2.4.6.bb
+++ b/packages/glib-2.0/glib-2.0_2.4.6.bb
@@ -31,10 +31,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.6.0.bb b/packages/glib-2.0/glib-2.0_2.6.0.bb
index 9e55bf0305..e59d9cc282 100644
--- a/packages/glib-2.0/glib-2.0_2.6.0.bb
+++ b/packages/glib-2.0/glib-2.0_2.6.0.bb
@@ -30,10 +30,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.6.1.bb b/packages/glib-2.0/glib-2.0_2.6.1.bb
index 289b81aaaf..682df4dbbb 100644
--- a/packages/glib-2.0/glib-2.0_2.6.1.bb
+++ b/packages/glib-2.0/glib-2.0_2.6.1.bb
@@ -30,10 +30,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.6.2.bb b/packages/glib-2.0/glib-2.0_2.6.2.bb
index 289b81aaaf..682df4dbbb 100644
--- a/packages/glib-2.0/glib-2.0_2.6.2.bb
+++ b/packages/glib-2.0/glib-2.0_2.6.2.bb
@@ -30,10 +30,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.6.3.bb b/packages/glib-2.0/glib-2.0_2.6.3.bb
index 289b81aaaf..682df4dbbb 100644
--- a/packages/glib-2.0/glib-2.0_2.6.3.bb
+++ b/packages/glib-2.0/glib-2.0_2.6.3.bb
@@ -30,10 +30,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.6.4.bb b/packages/glib-2.0/glib-2.0_2.6.4.bb
index 289b81aaaf..682df4dbbb 100644
--- a/packages/glib-2.0/glib-2.0_2.6.4.bb
+++ b/packages/glib-2.0/glib-2.0_2.6.4.bb
@@ -30,10 +30,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.8.1.bb b/packages/glib-2.0/glib-2.0_2.8.1.bb
index ecb7115dd1..218cb53c46 100644
--- a/packages/glib-2.0/glib-2.0_2.8.1.bb
+++ b/packages/glib-2.0/glib-2.0_2.8.1.bb
@@ -29,10 +29,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.8.2.bb b/packages/glib-2.0/glib-2.0_2.8.2.bb
index d72803b564..d26f248447 100644
--- a/packages/glib-2.0/glib-2.0_2.8.2.bb
+++ b/packages/glib-2.0/glib-2.0_2.8.2.bb
@@ -29,10 +29,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.8.4.bb b/packages/glib-2.0/glib-2.0_2.8.4.bb
index 778e3118d1..c11e8bf887 100644
--- a/packages/glib-2.0/glib-2.0_2.8.4.bb
+++ b/packages/glib-2.0/glib-2.0_2.8.4.bb
@@ -27,10 +27,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {
diff --git a/packages/glib-2.0/glib-2.0_2.8.6.bb b/packages/glib-2.0/glib-2.0_2.8.6.bb
index eea05316b1..f28b370f89 100644
--- a/packages/glib-2.0/glib-2.0_2.8.6.bb
+++ b/packages/glib-2.0/glib-2.0_2.8.6.bb
@@ -26,10 +26,7 @@ S = "${WORKDIR}/glib-${PV}"
inherit autotools pkgconfig gettext
-python () {
- if bb.data.getVar("USE_NLS", d, 1) == "no":
- raise bb.parse.SkipPackage("${PN} requires native language support.")
-}
+require glib-2.0.inc
acpaths = ""
do_configure_prepend () {