aboutsummaryrefslogtreecommitdiffstats
path: root/packages/glibc
diff options
context:
space:
mode:
authorErik Hovland <erik@hovland.org>2006-05-19 23:10:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-19 23:10:29 +0000
commit5df2eacd530758fbd5cca526f606d2e95417c0ed (patch)
treebec832af2d49aca45cd4443a956c221fe0e1b0ee /packages/glibc
parent9c257cb57a9bc7bbbf90310cf592aeaa24cc1960 (diff)
parentc2420f459bde3d91cc8fc4b585e1ba49edb858f0 (diff)
downloadopenembedded-5df2eacd530758fbd5cca526f606d2e95417c0ed.tar.gz
merge of 46c1cdea7bf65d8ba6bbe951e7408d24d5b05d06
and 8cd65284f1d330175ae2d67c03b8a2c1b41e858a
Diffstat (limited to 'packages/glibc')
-rw-r--r--packages/glibc/glibc-cvs-2.3.5/superh-fcntl.patch40
-rw-r--r--packages/glibc/glibc_2.3.5+cvs20050627.bb9
2 files changed, 46 insertions, 3 deletions
diff --git a/packages/glibc/glibc-cvs-2.3.5/superh-fcntl.patch b/packages/glibc/glibc-cvs-2.3.5/superh-fcntl.patch
new file mode 100644
index 0000000000..364b9e1b32
--- /dev/null
+++ b/packages/glibc/glibc-cvs-2.3.5/superh-fcntl.patch
@@ -0,0 +1,40 @@
+--- sysdeps/unix/sysv/linux/sh/bits/fcntl.h_orig 2006-05-16 16:58:30.000000000 +0000
++++ sysdeps/unix/sysv/linux/sh/bits/fcntl.h 2006-05-16 16:58:49.000000000 +0000
+@@ -90,6 +90,12 @@
+ # define F_GETSIG 11 /* Get number of signal to be sent. */
+ #endif
+
++#ifdef __USE_GNU
++# define F_SETLEASE 1024 /* Set a lease. */
++# define F_GETLEASE 1025 /* Enquire what lease is active. */
++# define F_NOTIFY 1026 /* Request notifications on a directory */
++#endif
++
+ /* For F_[GET|SET]FL. */
+ #define FD_CLOEXEC 1 /* actually anything with low bit set goes */
+
+@@ -111,6 +117,24 @@
+ # define LOCK_UN 8 /* remove lock */
+ #endif
+
++#ifdef __USE_GNU
++# define LOCK_MAND 32 /* this is a mandatory flock: */
++# define LOCK_READ 64 /* ...which allows concurrent read operations. */
++# define LOCK_WRITE 128 /* ...which allows concurrent write operations. */
++# define LOCK_RW 192 /* ...which allows concurrent read & write operations. */
++#endif
++
++#ifdef __USE_GNU
++/* Types of directory notifications that may be requested with F_NOTIFY. */
++# define DN_ACCESS 0x00000001 /* File Acessed. */
++# define DN_MODIFY 0x00000002 /* File Modified. */
++# define DN_CREATE 0x00000004 /* File created. */
++# define DN_DELETE 0x00000008 /* File removed. */
++# define DN_RENAME 0x00000010 /* File renamed. */
++# define DN_ATTRIB 0x00000020 /* File changed attributes. */
++# define DN_MULTISHOT 0x80000000 /* Don't remove notifier. */
++#endif
++
+ struct flock
+ {
+ short int l_type; /* Type of lock: F_RDLCK, F_WRLCK, or F_UNLCK. */
diff --git a/packages/glibc/glibc_2.3.5+cvs20050627.bb b/packages/glibc/glibc_2.3.5+cvs20050627.bb
index a5fe3e6e40..024ba1d901 100644
--- a/packages/glibc/glibc_2.3.5+cvs20050627.bb
+++ b/packages/glibc/glibc_2.3.5+cvs20050627.bb
@@ -7,7 +7,7 @@ MAINTAINER = "Phil Blundell <pb@handhelds.org>"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs-2.3.5"
SRCDATE = "20050627"
-PR = "r4"
+PR = "r6"
GLIBC_ADDONS ?= "ports,linuxthreads"
GLIBC_EXTRA_OECONF ?= ""
@@ -60,8 +60,11 @@ SRC_URI = "http://familiar.handhelds.org/source/v0.8.3/stash_libc_sources.redhat
# seems to fail on tls platforms
SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch;patch=1"
-# Build fails on sh4 unless no-z-defs is defined
-SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
+# Build fails on sh3 and sh4 without additional patches
+SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1 \
+ file://superh-fcntl.patch;patch=1;pnum=0"
+SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1 \
+ file://superh-fcntl.patch;patch=1;pnum=0"
S = "${WORKDIR}/libc"
B = "${WORKDIR}/build-${TARGET_SYS}"