aboutsummaryrefslogtreecommitdiffstats
path: root/packages/glibc
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2006-06-06 20:47:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-06 20:47:46 +0000
commita072b606633f34ac647d49a735713d5a0a4cc9dc (patch)
treebb074bb6c6c5b06f7ef5a0e2d58d27cd0edf4b8b /packages/glibc
parent15b83e88c759a5c72f3731950cab05c42edb37f2 (diff)
downloadopenembedded-a072b606633f34ac647d49a735713d5a0a4cc9dc.tar.gz
glibc_2.3.5+cvs20050627: added patch for raise.c for compilation with gcc 4.1.1
see also http://sourceware.org/ml/libc-ports/2005-11/msg00018.html
Diffstat (limited to 'packages/glibc')
-rw-r--r--packages/glibc/glibc-cvs-2.3.5/raise.patch37
-rw-r--r--packages/glibc/glibc_2.3.5+cvs20050627.bb3
2 files changed, 39 insertions, 1 deletions
diff --git a/packages/glibc/glibc-cvs-2.3.5/raise.patch b/packages/glibc/glibc-cvs-2.3.5/raise.patch
new file mode 100644
index 0000000000..16b4cb85a1
--- /dev/null
+++ b/packages/glibc/glibc-cvs-2.3.5/raise.patch
@@ -0,0 +1,37 @@
+--- glibc.orig/linuxthreads/sysdeps/unix/sysv/linux/raise.c 2003-01-02 19:38:38.000000000 -0500
++++ glibc/linuxthreads/sysdeps/unix/sysv/linux/raise.c 2005-10-31 14:19:58.000000000 -0500
+@@ -1,4 +1,4 @@
+-/* Copyright (C) 1991, 1996, 2002, 2003 Free Software Foundation, Inc.
++/* Copyright (C) 1991, 1996, 2002, 2003, 2005 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+@@ -18,10 +18,13 @@
+
+ #include <signal.h>
+ #include <unistd.h>
+-#include <bits/libc-lock.h>
+
+-#ifndef SHARED
++#ifndef IS_IN_rtld
++# include <bits/libc-lock.h>
++
++# ifndef SHARED
+ weak_extern (__pthread_raise)
++# endif
+ #endif
+
+ /* Raise the signal SIG. */
+@@ -29,8 +32,12 @@ int
+ raise (sig)
+ int sig;
+ {
++#ifdef IS_IN_rtld
++ return __kill (__getpid (), sig);
++#else
+ return __libc_maybe_call2 (pthread_raise, (sig),
+ __kill (__getpid (), sig));
++#endif
+ }
+ libc_hidden_def (raise)
+ weak_alias (raise, gsignal
diff --git a/packages/glibc/glibc_2.3.5+cvs20050627.bb b/packages/glibc/glibc_2.3.5+cvs20050627.bb
index ff434d2a1b..fc5abcc266 100644
--- a/packages/glibc/glibc_2.3.5+cvs20050627.bb
+++ b/packages/glibc/glibc_2.3.5+cvs20050627.bb
@@ -7,7 +7,7 @@ MAINTAINER = "Phil Blundell <pb@handhelds.org>"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs-2.3.5"
SRCDATE = "20050627"
-PR = "r6"
+PR = "r7"
GLIBC_ADDONS ?= "ports,linuxthreads"
GLIBC_EXTRA_OECONF ?= ""
@@ -54,6 +54,7 @@ SRC_URI = "http://familiar.handhelds.org/source/v0.8.3/stash_libc_sources.redhat
file://dl-cache-libcmp.patch;patch=1 \
file://ldsocache-varrun.patch;patch=1 \
file://5090_all_stubs-rule-fix.patch;patch=1 \
+ file://raise.patch;patch=1 \
file://etc/ld.so.conf \
file://generate-supported.mk"