aboutsummaryrefslogtreecommitdiffstats
path: root/packages/glibc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-19 19:36:12 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-19 19:36:12 +0000
commiteb2a9729b6fcfa1edc02ccfb9bef4ce02b26ba95 (patch)
treeab0c8c6c4da0ee229fff9ef9b6f7dd669fea6da2 /packages/glibc
parent8f278eee0ffb4a56f560d2f8e654058c7d4d74f0 (diff)
downloadopenembedded-eb2a9729b6fcfa1edc02ccfb9bef4ce02b26ba95.tar.gz
glibc: drop 2.4, since it is confirmed to be nonworking on arm
Diffstat (limited to 'packages/glibc')
-rw-r--r--packages/glibc/glibc-initial_2.4.bb45
-rw-r--r--packages/glibc/glibc-intermediate_2.4.bb13
-rw-r--r--packages/glibc/glibc_2.4.bb205
3 files changed, 0 insertions, 263 deletions
diff --git a/packages/glibc/glibc-initial_2.4.bb b/packages/glibc/glibc-initial_2.4.bb
deleted file mode 100644
index f13419a413..0000000000
--- a/packages/glibc/glibc-initial_2.4.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-require glibc_${PV}.bb
-
-DEPENDS = "linux-libc-headers"
-PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-PACKAGES = ""
-
-do_configure () {
- sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
- chmod +x ${S}/configure
- CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
- --without-cvs --disable-sanity-checks \
- --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
- --enable-hacker-mode
- if grep -q GLIBC_2.3 ${S}/ChangeLog; then
- # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
- # Fortunately, we don't need errlist-compat.c, since we just need .h files,
- # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
- # Another workaround might be to tell configure to not use any cross options to $(CC).
- # The real fix would be to get install-headers to not generate errlist-compat.c.
- make sysdeps/gnu/errlist.c
- mkdir -p stdio-common
- touch stdio-common/errlist-compat.c
- fi
-}
-
-do_compile () {
- :
-}
-
-do_stage () {
- oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers
-
- # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
- # so do them by hand. We can tolerate an empty stubs.h for the moment.
- # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
- mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu
- touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h
- cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h
-}
-
-do_install () {
- :
-}
diff --git a/packages/glibc/glibc-intermediate_2.4.bb b/packages/glibc/glibc-intermediate_2.4.bb
deleted file mode 100644
index 75dae48532..0000000000
--- a/packages/glibc/glibc-intermediate_2.4.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require glibc_${PV}.bb
-
-DEFAULT_PREFERENCE = "-1"
-
-do_install () {
- :
-}
-
-PACKAGES = ""
-PROVIDES = "virtual/${TARGET_PREFIX}libc-for-gcc"
-DEPENDS = "virtual/${TARGET_PREFIX}gcc-initial linux-libc-headers"
-GLIBC_ADDONS = "nptl,ports"
-GLIBC_EXTRA_OECONF = ""
diff --git a/packages/glibc/glibc_2.4.bb b/packages/glibc/glibc_2.4.bb
deleted file mode 100644
index 45131eafad..0000000000
--- a/packages/glibc/glibc_2.4.bb
+++ /dev/null
@@ -1,205 +0,0 @@
-DESCRIPTION = "GNU C Library"
-HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
-LICENSE = "LGPL"
-SECTION = "libs"
-PRIORITY = "required"
-PR = "r10"
-
-# the -isystem in bitbake.conf screws up glibc do_stage
-BUILD_CPPFLAGS = "-I${STAGING_DIR}/${BUILD_SYS}/include"
-TARGET_CPPFLAGS = "-I${STAGING_DIR}/${TARGET_SYS}/include"
-
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4"
-
-GLIBC_ADDONS ?= "ports,nptl,libidn"
-GLIBC_EXTRA_OECONF ?= ""
-
-GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN"
-
-#
-# For now, we will skip building of a gcc package if it is a uclibc one
-# and our build is not a uclibc one, and we skip a glibc one if our build
-# is a uclibc build.
-#
-# See the note in gcc/gcc_3.4.0.oe
-#
-
-python __anonymous () {
- import bb, re
- uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
- if uc_os:
- raise bb.parse.SkipPackage("incompatible with target %s" %
- bb.data.getVar('TARGET_OS', d, 1))
-}
-
-# nptl needs unwind support in gcc, which can't be built without glibc.
-PROVIDES = "virtual/libc ${@['virtual/${TARGET_PREFIX}libc-for-gcc', '']['nptl' in '${GLIBC_ADDONS}']}"
-PROVIDES += "virtual/libintl virtual/libiconv"
-DEPENDS = "${@['virtual/${TARGET_PREFIX}gcc-initial', 'virtual/${TARGET_PREFIX}gcc']['nptl' in '${GLIBC_ADDONS}']} linux-libc-headers"
-RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
-INHIBIT_DEFAULT_DEPS = "1"
-
-# file://noinfo.patch;patch=1
-# file://ldconfig.patch;patch=1;pnum=0
-# file://arm-machine-gmon.patch;patch=1;pnum=0 \
-# \
-# file://arm-ioperm.patch;patch=1;pnum=0 \
-# file://ldd.patch;patch=1;pnum=0 \
-SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-2.4.tar.bz2 \
- ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-2.4.tar.bz2 \
- ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-2.4.tar.bz2 \
- file://arm-memcpy.patch;patch=1 \
- file://arm-longlong.patch;patch=1 \
- file://fhs-linux-paths.patch;patch=1 \
- file://dl-cache-libcmp.patch;patch=1 \
- file://ldsocache-varrun.patch;patch=1 \
- file://nptl-crosscompile.patch;patch=1 \
- file://glibc-2.4-compile.patch;patch=1 \
- file://glibc-2.4-openat-3.patch;patch=1 \
- file://fixup-aeabi-syscalls.patch;patch=1 \
- file://zecke-sane-readelf.patch;patch=1 \
- file://generic-bits_select.h \
- file://generic-bits_types.h \
- file://generic-bits_typesizes.h \
- file://generic-bits_time.h \
- file://etc/ld.so.conf \
- file://generate-supported.mk"
-
-
-# Build fails on sh3 and sh4 without additional patches
-SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
-SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
-
-S = "${WORKDIR}/glibc-2.4"
-B = "${WORKDIR}/build-${TARGET_SYS}"
-
-inherit autotools
-
-EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
- --without-cvs --disable-profile --disable-debug --without-gd \
- --enable-clocale=gnu \
- --enable-add-ons=${GLIBC_ADDONS} \
- --with-headers=${STAGING_INCDIR} \
- --without-selinux \
- ${GLIBC_EXTRA_OECONF}"
-
-EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
-
-def get_glibc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--without-fp"
- return ""
-
-do_munge() {
- # Integrate ports and libidn into tree
- mv ${WORKDIR}/glibc-ports-${PV} ${S}/ports
- mv ${WORKDIR}/glibc-libidn-${PV} ${S}/libidn
-
- # Ports isn't really working... Fix it
- # Some of this is rather dirty, but it seems to be the only
- # quick way to get this cruft to compile
- rm -rf ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads
- ln -s nptl ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads
- cp ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
- cp ${S}/sysdeps/wordsize-32/bits/wordsize.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
- cp ${WORKDIR}/generic-bits_select.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/select.h
- cp ${WORKDIR}/generic-bits_types.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/types.h
- cp ${WORKDIR}/generic-bits_typesizes.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/typesizes.h
- cp ${WORKDIR}/generic-bits_time.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/time.h
- # Copy in generic stuff for not yet implemented headers
- for i in ${S}/bits/*.h; do
- F=`basename $i`
- [ "$F" = "local_lim.h" ] && continue
- [ "$F" = "errno.h" ] && continue
- test -e ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/$F || test -e ${S}/ports/sysdeps/arm/bits/$F || test -e ${S}/sysdeps/unix/sysv/linux/bits/$F || test -e ${S}/sysdeps/ieee754/bits/$F || cp $i ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
- done
- # This is harmful; we need to get the one from nptl/sysdeps/pthreads
- rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/libc-lock.h
- # Obsoleted by sysdeps/arm/{fpu,eabi}/bits/fenv.h
- rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/fenv.h
- # Obsoleted by sysdeps/gnu/bits/utmp.h
- rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/utmp.h
-}
-
-addtask munge before do_patch after do_unpack
-
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
-# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
-# version check and doesn't really help with anything
- if [ -z "`which rpcgen`" ]; then
- echo "rpcgen not found. Install glibc-devel."
- exit 1
- fi
- (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
- CPPFLAGS="" oe_runconf
-}
-
-rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
- yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
- rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
-
-do_compile () {
- # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
- unset LDFLAGS
- base_do_compile
- (
- cd ${S}/sunrpc/rpcsvc
- for r in ${rpcsvc}; do
- h=`echo $r|sed -e's,\.x$,.h,'`
- rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
- done
- )
-}
-
-do_stage() {
- rm -f ${STAGING_LIBDIR}/libc.so.6
- oe_runmake 'install_root=${STAGING_DIR}/${HOST_SYS}' \
- 'includedir=/include' 'libdir=/lib' 'slibdir=/lib' \
- '${STAGING_LIBDIR}/libc.so.6' \
- install-headers install-lib
-
- install -d ${STAGING_INCDIR}/gnu \
- ${STAGING_INCDIR}/bits \
- ${STAGING_INCDIR}/rpcsvc
- install -m 0644 ${S}/include/gnu/stubs.h ${STAGING_INCDIR}/gnu/
- install -m 0644 ${B}/bits/stdio_lim.h ${STAGING_INCDIR}/bits/
- install -m 0644 misc/syscall-list.h ${STAGING_INCDIR}/bits/syscall.h
- for r in ${rpcsvc}; do
- h=`echo $r|sed -e's,\.x$,.h,'`
- install -m 0644 ${S}/sunrpc/rpcsvc/$h ${STAGING_INCDIR}/rpcsvc/
- done
- for i in libc.a libc_pic.a libc_nonshared.a; do
- install -m 0644 ${B}/$i ${STAGING_LIBDIR}/ || die "failed to install $i"
- done
- echo 'GROUP ( libpthread.so.0 libpthread_nonshared.a )' > ${STAGING_LIBDIR}/libpthread.so
- echo 'GROUP ( libc.so.6 libc_nonshared.a )' > ${STAGING_LIBDIR}/libc.so
-
- rm -f ${CROSS_DIR}/${TARGET_SYS}/lib/libc.so.6
- oe_runmake 'install_root=${CROSS_DIR}/${TARGET_SYS}' \
- 'includedir=/include' 'libdir=/lib' 'slibdir=/lib' \
- '${CROSS_DIR}/${TARGET_SYS}/lib/libc.so.6' \
- install-headers install-lib
-
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/gnu \
- ${CROSS_DIR}/${TARGET_SYS}/include/bits \
- ${CROSS_DIR}/${TARGET_SYS}/include/rpcsvc
- install -m 0644 ${S}/include/gnu/stubs.h ${CROSS_DIR}/${TARGET_SYS}/include/gnu/
- install -m 0644 ${B}/bits/stdio_lim.h ${CROSS_DIR}/${TARGET_SYS}/include/bits/
- install -m 0644 misc/syscall-list.h ${CROSS_DIR}/${TARGET_SYS}/include/bits/syscall.h
- for r in ${rpcsvc}; do
- h=`echo $r|sed -e's,\.x$,.h,'`
- install -m 0644 ${S}/sunrpc/rpcsvc/$h ${CROSS_DIR}/${TARGET_SYS}/include/rpcsvc/
- done
-
- for i in libc.a libc_pic.a libc_nonshared.a; do
- install -m 0644 ${B}/$i ${CROSS_DIR}/${TARGET_SYS}/lib/ || die "failed to install $i"
- done
- echo 'GROUP ( libpthread.so.0 libpthread_nonshared.a )' > ${CROSS_DIR}/${TARGET_SYS}/lib/libpthread.so
- echo 'GROUP ( libc.so.6 libc_nonshared.a )' > ${CROSS_DIR}/${TARGET_SYS}/lib/libc.so
-}
-
-require glibc-package.bbclass